Bug 72465 - Cannot change id of cd audio device in gnome-cd player
Cannot change id of cd audio device in gnome-cd player
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Jay Turner
:
: 72575 (view as bug list)
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-23 20:58 EDT by Gerry Tool
Modified: 2015-01-07 18:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 19:49:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerry Tool 2002-08-23 20:58:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
I have two CD drives and the second one (/dev/cdrom1)is the one connected to my
sound card.  When I change the CD player device in the Preferences dialog from
the default /dev/cdrom to /dev/cdrom1 and click Apply changes, it does not
"stick".  After close and reopen of the dialog it is still set to the default. 
Hence, I cannot play audio cds in Gnome - setting this and playing cds in Kscd
in KDE works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.In Gnome, insert audio CD into /dev/cdrom1
2.Gnome CD player starts and indicates "Drive open."
3.Click on Open Preferences button to open dialog
4.Change value of CD player device from default /dev/cdrom to /dev/cdrom1
5.Click Apply change
6.Click Close.  CD Player still indicates "Drive open."
7.Open preferences dialog again and device is back to /dev/cdrom.
	

Actual Results:  CD player device will not change to /dev/cdrom1

Expected Results:  CD player device should change to /dev/cdrom1 and cd player
should play audio cd in that drive.

Additional info:
Comment 1 Jackie Meese 2002-08-27 09:34:27 EDT
I second this, both SCSI CDs on the same SCSI bus.  I really do'nt feel like
opening my box to change the audio cable....
Comment 2 Owen Taylor 2002-08-27 18:18:14 EDT
I think I have this all working nicely now:

I'd really apprecatiate it if you could test out the RPMs in:

 http://people.redhat.com/otaylor/tmp/cdrom-testing

(I've included the SRPMs for reference, but the i386.rpms should
install fine on (null))

and see if they produce the following behavior with multiple
CD-ROM drives:

 - CD device can be set in gnome-cd preferences dialog,
   and applies to that copy of gnome-cd and subsequent
   copies launched without any command line options.

 - gnome-cd can be launched as 'gnome-cd --device=/dev/cdrom1'
   and it will use the specified device, and ignore the
   preference.

 - Multiple panel cdplayer (Multimedia/CD Player) applets can
   be added, and each configured to point to a different
   CD Player through the preferences.

 - With magicdev running, when a CD is inserted:

    - If no gnome-cd application or cd player applet for the 
      CD drive where the CD is inserted is running, 
      a new 'gnome-cd' window will be opened for that device.

    - If a gnome-cd application or cd player applet is running,
      the CD will start playing, but no new window will be opened.

You may have to unset the current magicdev CD play command:
to get magicdev to use the right command when a CD is inserted;
To do this, run:

 gconftool-2 --unset /apps/magicdev/cd_play_command

From the command line.

Thanks,
                                    Owen
Comment 3 Gerry Tool 2002-08-27 22:29:03 EDT
I updated to your binary rpms and tested.  I executed the magicdev command you
specified. /dev/cdrom1 now works for me.  However, some of the behaviour is not
as you suggest.

Launching from command line works as you suggest.

With two panel applets, both point to the device that was specified last in one
of the preference dialogs.

When a cd is inserted, a player opens and plays the cd regardless of which drive
has been specified in the preferences.  If the last one specified in preferences
was the other drive, the preferences still point to that drive, but it will play
the cd in the non-specified drive.

If a player window is already opem, a new one opens when the cd is inserted
regardless of which one was specified in the open player's preferences.  If the
drive is changed in the initial player's preferences (with second one initially
playing the cd), the initial player assumes control of the playing.

Hope this helps.
Gerry Tool
Comment 4 Gerry Tool 2002-08-27 22:31:25 EDT
Here is a copy of my rpm update:

[root@gstpc rpms]# rpm -Uvh *.rpm
warning: magicdev-1.1.2-1.i386.rpm: Header V3 DSA signature: NOKEY, key ID 897da
07a
Preparing...                ########################################### [100%]
   1:gnome-media            ########################################### [ 33%]
Cannot stat file: /usr/share/gnome/help/glade-2/C/faq.xml : No such file or
directory
   2:gnome-applets          ########################################### [ 67%]
   3:magicdev               ########################################### [100%]
[root@gstpc rpms]# gconftool-2 --unset /apps/magicdev/cd_play_command

Gerry
Comment 5 Owen Taylor 2002-08-28 15:25:38 EDT
*** Bug 72575 has been marked as a duplicate of this bug. ***
Comment 6 Owen Taylor 2003-01-13 19:49:06 EST
I stuck a second CD drive into the system and did a bunch of testing,
and it seems to work well. (There was one bug, but that seemed to
be new since 8.0)

Note You need to log in before you can comment on or make changes to this bug.