Bug 72478 - metacity doesn't work with full screen option form mplayer 0.90pre6
metacity doesn't work with full screen option form mplayer 0.90pre6
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-24 07:20 EDT by Jacek Kujawa
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-02 10:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacek Kujawa 2002-08-24 07:20:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When I choose fullscreen option from mplayer a window raise on all screen except
a panell bar (gnome panel) on the top and bottom of the desktop. This option
should hide this panels. I revert this option from mplayer (choose normal
windows) the playing window disappear. Everythinh works great if I just switch
off a metacity or run sawfish  instead.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.like in description
2.
3.
	

Additional info:
Comment 1 Havoc Pennington 2002-08-24 17:54:45 EDT
2.4.0.92-4 should fix
Comment 2 Sean Dilda 2002-08-29 23:58:19 EDT
I also experienced the problem described with mplayer.. and also had the problem
of the gnome panel not going away in full screen mode with xine.

I upgraded metacity to 2.4.0.92-5 and the problem with the gnome menu went away
in both programs.   However, with mplayer, whenever you try to leave fullscreen
mode, it blinks away from fullscreen mode, but then comes right back.  I am not
sure if this is a metacity or mplayer issue.  There is no problem leaving
fullscreen mode with xine.

Version of mplayer that I tested with are 0.90pre5 and 0.90pre6
Comment 3 Havoc Pennington 2002-08-30 01:50:53 EDT
Hmm, will look.
Comment 4 Scott Russell 2002-10-15 23:21:17 EDT
Confimed that metacity-2.4.0.92-5 and mplayer 0.90pre8-3.2 has this fullscreen
switching bug still. There's a small thread about it on the mplayer-users list:

http://mplayerhq.hu/pipermail/mplayer-users/2002-September/021249.html

Also, bug 71163 appears to be a duplicate of this one? Not sure which one I
should be entering info into :)
Comment 5 Havoc Pennington 2002-10-16 10:32:29 EDT
It's fixed in CVS metacity.
Comment 6 Havoc Pennington 2003-01-02 10:59:46 EST
This is as fixed as it can be in metacity, if still not working in rawhide, 
we need to fix mplayer. I seem to remember someone saying mplayer worked now 
though.

Note You need to log in before you can comment on or make changes to this bug.