Bug 724950 - [abrt] Zim-0.52-1.fc15: index.py:1240:get_all_pages_index:AssertionError: BUG: could not find path in index
[abrt] Zim-0.52-1.fc15: index.py:1240:get_all_pages_index:AssertionError: BUG...
Status: CLOSED DUPLICATE of bug 750055
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Weyl
Fedora Extras Quality Assurance
abrt_hash:a888bfba9cf3cf71302da8fee32...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-22 08:11 EDT by jan.basko
Modified: 2011-12-16 05:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-16 05:16:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jan.basko 2011-07-22 08:11:12 EDT
abrt version: 2.0.3
architecture:   i686
cmdline:        /usr/bin/python /usr/bin/zim
comment:        I cannot remember this, im sorry
component:      Zim
executable:     /usr/bin/zim
kernel:         2.6.38.8-35.fc15.i686.PAE
os_release:     Fedora release 15 (Lovelock)
package:        Zim-0.52-1.fc15
reason:         index.py:1240:get_all_pages_index:AssertionError: BUG: could not find path in index
time:           Thu Jul 14 14:51:28 2011
uid:            500
username:       basko_j

backtrace:
:index.py:1240:get_all_pages_index:AssertionError: BUG: could not find path in index
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 391, in on_page_deleted
:    treepaths = self.get_treepaths(path)
:  File "/usr/lib/python2.7/site-packages/zim/plugins/tags.py", line 471, in get_treepaths
:    pageindex = self.index.get_all_pages_index(p)
:  File "/usr/lib/python2.7/site-packages/zim/index.py", line 1240, in get_all_pages_index
:    assert False, 'BUG: could not find path in index'
:AssertionError: BUG: could not find path in index
:
:Local variables in innermost frame:
:i: 10
:cursor: <sqlite3.Cursor object at 0x93506e0>
:path: <IndexPath: LINUX&UNIX:commands:user@]host[:file [file>
:self: <Index object at 0x9287a7c (zim+index+Index at 0x9317610)>
:row: <sqlite3.Row object at 0x9332d90>
Comment 1 Robin Lee 2011-12-16 05:16:24 EST

*** This bug has been marked as a duplicate of bug 750055 ***

Note You need to log in before you can comment on or make changes to this bug.