Bug 72502 - cups references /usr/local/bin/gs
Summary: cups references /usr/local/bin/gs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: cups (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-24 18:06 UTC by Alex Yacoub
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 07:27:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Yacoub 2002-08-24 18:06:42 UTC
Description of Problem:

cups will not print on my machine because it tries to filter files through
/usr/local/bin/gs instead of /usr/bin/gs.

The problem is in /usr/lib/cups/filter/pstoraster:
[cut]
# Installation directories...
prefix=/usr/local
exec_prefix=${prefix}
bindir=${exec_prefix}/bin
[cut]
# Now run Ghostscript...
$bindir/gs $gsopts -sOUTPUTFILE="%stdout" $profile $ifile
[cut]

Version-Release number of selected component (if applicable):
I'm using limbo2, but I upgraded the ghostscript and cups packages to the
packages in null.


How to debug:
Set LogLevel in /etc/cups/cupsd.conf to debug.  Try to print.  Grep the
/var/log/cups/error_log file for gs.

Error:
D [24/Aug/2002:13:51:58 -0400] /usr/lib/cups/filter/pstoraster: line 55:
/usr/local/bin/gs: No such file or directory

Reproducible always, for me.

Additional Information:
Workaround: make a symlink from /usr/local/bin/gs to /usr/bin/gs, or change
pstoraster

Comment 1 Tim Waugh 2002-08-28 07:27:02 UTC
This should already be fixed in cups-1.1.15-9.  Please confirm.

Comment 2 Jay Turner 2002-08-28 12:55:05 UTC
Fix confirmed in cups-1.1.15-9.


Note You need to log in before you can comment on or make changes to this bug.