Bug 72518 - Unable to install with GeForce 3 TI 200 with DVI based Flatpanel
Unable to install with GeForce 3 TI 200 with DVI based Flatpanel
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
null
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-24 17:16 EDT by coolcsh
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 04:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My modified version of the nv-dfp patch, against XFree86 4.2.0-8 (45.56 KB, patch)
2002-08-30 04:28 EDT, Barry K. Nathan
no flags Details | Diff

  None (edit)
Description coolcsh 2002-08-24 17:16:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
If I try and install (null) on a machine with a DVI based flatpanel monitor
connected to a Nvidia GeForce 3 Ti200 the monitor is undetected and the
graphical install fails to display. Even worse if I install in text mode and
then later try and run X it appears that it trys to auto detect my monitor which
fails and never displays. Even if I hardcode or select Dell FP7200 Digital
during install

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot into graphical install.
2.Fails to detect DVI monitor
3.Blank screen
	

Actual Results:  got a blank screen

Expected Results:  should have detected DVI monitor

Additional info:
Comment 1 Michael Fulbright 2002-08-26 16:27:54 EDT
We do not currently have any code which can detect these types of monitors.

Assigning to XFree86 since it had problems even in manual configuration.
Comment 2 Barry K. Nathan 2002-08-30 03:38:12 EDT
XFree86 4.2 doesn't have support for the DVI output on the GeForces 3 Ti's, but
the support is in CVS. There was also a patch posted to the XPert list to add
support (it was intended for Macs I think, but it works on x86 boxes too). I
have a slightly hacked version of the patch (some cosmetic changes removed)
which applies against Red Hat's XFree86-4.2.0-8 and which I have running on
production machines.

Ok, I found the URL for the patch against XFree86 4.2.0:
http://www.xfree86.org/pipermail/xpert/2002-April/016962.html
Comment 3 Barry K. Nathan 2002-08-30 04:28:16 EDT
Created attachment 73924 [details]
My modified version of the nv-dfp patch, against XFree86 4.2.0-8
Comment 4 Barry K. Nathan 2002-08-30 04:36:44 EDT
I believe the attachment should be able to apply cleanly to XFree86-4.2.0-67.6.
(More precisely, I believe it should be relatively easy to integrate this patch
into the XFree86 RPMs, if Red Hat wishes to do that. I have not tried building
modified XFree86-4.2.0-67.6 RPMs yet, however.)
Comment 5 Mike A. Harris 2002-09-01 06:31:43 EDT
As noted above, XFree86 4.2.0 does not support DVI output on Nvidia
hardware.  As such this is not a bug, but rather just a hardware
feature which is not supported.

The CVS development Nvidia code is not considered clean to apply
to a stable build at this point in time.  This support will have
to wait until XFree86 4.3.0 is released and integrated into
Red Hat Linux.

Closing bug as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.