This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 725218 - [ru_RU] vncviewer dialog not showing Russian symbols
[ru_RU] vncviewer dialog not showing Russian symbols
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: i18n, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-24 07:09 EDT by Alexei Panov
Modified: 2013-04-30 19:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 14:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the error (616.70 KB, image/png)
2011-07-24 07:09 EDT, Alexei Panov
no flags Details
error screenshoot (1.04 MB, image/png)
2011-07-24 07:33 EDT, Alexey Perezhogin
no flags Details
proposed patch (14.04 KB, patch)
2012-06-25 23:33 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Alexei Panov 2011-07-24 07:09:40 EDT
Created attachment 514913 [details]
screenshot of the error

Description of problem:
I've run vncviewer, in dialog of the application instead of Russian words - the characters "?". See screenshot in attachments.

Version-Release number of selected component (if applicable):
tigervnc 1.0.90-4.fc15

How reproducible:
Always

Steps to Reproduce:
1. yum install tigervnc
2. run LANG=ru_RU.UTF-8 vncviewer

Actual results:
The characters "?" instead Russian symbols.

Expected results:
Normal application dialog in Russian.

Additional info:
My locale:
$ locale
LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

If I'll be run 
$ LANG=C vncviewer
all works fine, but in English (see screenshot).
With LANG=ru_UA.UTF-8 bug is present too.
Comment 1 Alexey Perezhogin 2011-07-24 07:25:44 EDT
Confirm. tigervnc 1.0.90-4.
Comment 2 Alexey Perezhogin 2011-07-24 07:33:21 EDT
Created attachment 514916 [details]
error screenshoot
Comment 3 Akira TAGOH 2012-06-25 22:17:50 EDT
This issue still persists in f17 and there are similar problems for non-English languages too because it doesn't use i18n supported APIs.
Comment 4 Akira TAGOH 2012-06-25 23:33:03 EDT
Created attachment 594340 [details]
proposed patch

Well, this is minimal patch to make it internationalized. it may needs to have some customization for the XLFD or XLFD may needs to be translatable for their preferences.

Though honestly it would be better rewriting the code to get rid of the legacy font system and use fontconfig and Xft at least, instead of applying this patch.

FWIW there seems another issue on building tigervnc so far. I can't completely build it to make the package because of fails in xserver. but was still possible to test vncviewer, but anyway.
Comment 5 Alexei Panov 2012-08-12 09:18:20 EDT
Thank you Akira. Patch works fine.
Comment 6 Adam Tkac 2013-03-12 14:32:16 EDT
This issue is no longer present in Fedora 18. Since viewer was completely rewriten in F18 and TigerVNC 1.1.X is officially dead, I'm not going to fix this issue in F17. Please upgrade to F18.

Note You need to log in before you can comment on or make changes to this bug.