This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 725342 - xm shutdown -H option dose not work for windows hvm guest
xm shutdown -H option dose not work for windows hvm guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xenpv-win (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-25 04:52 EDT by Pengzhen Cao
Modified: 2012-02-21 00:35 EST (History)
6 users (show)

See Also:
Fixed In Version: xenpv-win-1.3.11-1.el5
Doc Type: Bug Fix
Doc Text:
Cause - Windows guests did not acknowledge an "xm shutdown -H" operation started from the host. Consequence - Attempting to turn a Windows virtual machine off with "xm shutdown -H" will not have any effect. Furthermore, it will prevent "xm shutdown" from working until the virtual machine is rebooted. Fix - The paravirtualized Xen network driver trigger a shutdown of the virtual machine when "xm shutdown -H" is sent. Result - (same as fix?...)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:35:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
qemu-dm.log (2.91 KB, text/plain)
2011-07-25 05:00 EDT, Pengzhen Cao
no flags Details
xend.log (102.85 KB, text/plain)
2011-07-25 05:00 EDT, Pengzhen Cao
no flags Details
xm_dmesg.log (5.52 KB, text/plain)
2011-07-25 05:01 EDT, Pengzhen Cao
no flags Details

  None (edit)
Description Pengzhen Cao 2011-07-25 04:52:43 EDT
Description of problem:
"xm shutdown -H" dose not work for windows hvm guest

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-274 and ealier build,  xen-3.0.3-132.el5

How reproducible:
100%

Steps to Reproduce:
1. create a windows hvm guest with "xm create xx.conf"
2. then try to shut down the guest with "xm shutdown -H" 
3.
  
Actual results:
VM could not be shutdown with "xm shutdown -H"

Expected results:
VM power down

Additional info:
1. Additional "xm shutdown" command not work for that domain, user need to shutdown the guest inside the guest os, or destroy it with "xm destroy"
2. This bug is not hardware specific and can be easily reproduced with a variety of windows guest OS.
Comment 1 Pengzhen Cao 2011-07-25 05:00:26 EDT
Created attachment 514992 [details]
qemu-dm.log
Comment 2 Pengzhen Cao 2011-07-25 05:00:57 EDT
Created attachment 514993 [details]
xend.log
Comment 3 Pengzhen Cao 2011-07-25 05:01:21 EDT
Created attachment 514994 [details]
xm_dmesg.log
Comment 4 Miroslav Rezanina 2011-07-28 07:11:59 EDT
What version of windows do you use for testing? I'm using win xp 32bit and I'm not able to reproduce...Do you had pv drivers installed?
Comment 5 Qixiang Wan 2011-07-28 07:29:44 EDT
(In reply to comment #4)
> What version of windows do you use for testing? I'm using win xp 32bit and I'm
> not able to reproduce...Do you had pv drivers installed?

yes, xen pv driver should be installed in the guest.
Comment 6 Miroslav Rezanina 2011-07-29 06:46:02 EDT
Reproduced the bug:

Guest with installed pv driver do not rreact on xm shutdown. Without drivers xm shutdown leads to destroy the guest.

Reassign to xenpv-win component.
Comment 7 Paolo Bonzini 2011-07-29 07:16:16 EDT
Correction from mirek on IRC: xm shutdown works if it is called first..if it is called after -H variant, it does not work anymore.
Comment 9 Shengnan Wang 2012-01-03 22:22:14 EST
I reproduced the bug with xenpv-win-1.3.4-9.el5.
Then update the pv driver to xenpv-win-1.3.12-3.el5 and do 5 times test for every kind of windows guest. The guest shutdown immediately via shutdown -H. 
So change this bug to VERIFIED.

Host: 2.6.18-301.el5
Xen: xen-3.0.3-135.el5
Guest: win2k3 i386 x86_64
       win2k8 i386 x86_64
       win7 i386 x86_64
       vista i386 x86_64
       xp 
       Win2008r2 

Bug verify steps:
1. Create a windows guest with cfg file. 
2. Shutdown the guest with "xm shutdown $domU_id -H" 
3. Check whether the guest shutdown immediately.
Comment 10 Paolo Bonzini 2012-01-16 04:17:59 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause - Windows guests did not acknowledge an "xm shutdown -H" operation started from the host.

Consequence - Attempting to turn a Windows virtual machine off with "xm shutdown -H" will not have any effect.  Furthermore, it will prevent "xm shutdown" from working until the virtual machine is rebooted.

Fix - The paravirtualized Xen network driver trigger a shutdown of the virtual machine when "xm shutdown -H" is sent.

Result - (same as fix?...)
Comment 11 errata-xmlrpc 2012-02-21 00:35:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0195.html

Note You need to log in before you can comment on or make changes to this bug.