Bug 72541 - date shows Finnish month names improperly
date shows Finnish month names improperly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-24 20:13 EDT by Petri T. Koistinen
Modified: 2016-11-24 10:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-28 11:35:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
date bug demo (12.13 KB, image/png)
2002-08-24 20:14 EDT, Petri T. Koistinen
no flags Details
Corrected version of picture. (12.03 KB, image/png)
2002-08-25 07:03 EDT, Petri T. Koistinen
no flags Details
Seeing is beliving and more info. (20.96 KB, image/png)
2002-10-27 06:24 EST, Petri T. Koistinen
no flags Details

  None (edit)
Description Petri T. Koistinen 2002-08-24 20:13:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.18-12.4 i686; Nav)

Description of problem:
Please see attached picture, there you can see "date" command misbehaving.

That printout is generated on /etc/rc.sysinit with this line:
action $"Setting clock $CLOCKDEF: `date`" date

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Reborn as native Finnish citizen.
2. Learn to understand Finnish etc. and install Red Hat Rawhide.
3. Set your locale to Finnish.
4. Boot system and read boot messages.

Actual Results:  See attached picture.

Additional info:

initscripts-6.91-1
sh-utils-2.0.12-2
Comment 1 Petri T. Koistinen 2002-08-24 20:14:20 EDT
Created attachment 72805 [details]
date bug demo
Comment 2 Petri T. Koistinen 2002-08-25 06:58:36 EDT
Ok, let's make correction to this bug repport.

First: Official month names (starting from January) in Finnish are:
tammikuu
helmikuu
maaliskuu
huhtikuu
toukokuu
kesdkuu (note, due bug in bugzilla, that d is actually "a with two dots on it".)
heindkuu (d on this month is also "a with two dots on it")
elokuu
syyskuu
lokakuu
marraskuu
joulukuu

As you can see month names in Finnish are quite long. They all have one
repeating part: "kuu" (which means "month" or "moon" in English) which can be
removed without losing any information.

I think that's the idea in date command output. So that picture is wrong, those
weird characters should be replaced with whitespace. 
Comment 3 Petri T. Koistinen 2002-08-25 07:03:04 EDT
Created attachment 72827 [details]
Corrected version of picture.
Comment 4 Bernhard Rosenkraenzer 2002-08-29 15:00:21 EDT
This is not reproducable here, on a current rawhide system.
It looks like it was a bug in strftime() in earlier versions of glibc.

[root@locutus sh-utils-2.0.12]# LANG=fi_FI date
to elo    29 21:00:49 CEST 2002
[root@locutus sh-utils-2.0.12]# LANG=fi_FI date --date="2001/01/01 12:34"
ma tammi   1 12:34:00 CET 2001
[root@locutus sh-utils-2.0.12]# rpm -q sh-utils glibc
sh-utils-2.0.12-2
glibc-2.2.90-23
Comment 5 Petri T. Koistinen 2002-08-31 14:37:15 EDT
IMPORTANT: you have to reboot your machine to see the effect with boot messages.

My locale is:
[petri@dsl-hkigw4l83 petri]$ locale
LANG=fi_FI@euro
LC_CTYPE="fi_FI@euro"
LC_NUMERIC="fi_FI@euro"
LC_TIME="fi_FI@euro"
LC_COLLATE="fi_FI@euro"
LC_MONETARY="fi_FI@euro"
LC_MESSAGES="fi_FI@euro"
LC_PAPER="fi_FI@euro"
LC_NAME="fi_FI@euro"
LC_ADDRESS="fi_FI@euro"
LC_TELEPHONE="fi_FI@euro"
LC_MEASUREMENT="fi_FI@euro"
LC_IDENTIFICATION="fi_FI@euro"
LC_ALL=
[petri@dsl-hkigw4l83 petri]$ rpm -q sh-utils glibc
sh-utils-2.0.12-3
glibc-2.2.90-26

The bug exists still. There are also other problems when I set Finnish as
default language from gdm language menu. 
Comment 6 Petri T. Koistinen 2002-10-26 07:58:34 EDT
This is fixed in Red Hat 8.0.
Comment 7 Petri T. Koistinen 2002-10-27 06:22:52 EST
I can see this again with Raw Hide after modified settings.
Comment 8 Petri T. Koistinen 2002-10-27 06:24:20 EST
Created attachment 82284 [details]
Seeing is beliving and more info.
Comment 9 Petri T. Koistinen 2002-11-20 16:51:30 EST
I guess this problem appears when you mix UTF-8 and Latin-9 locales. Other perhaps  
UTF-8 and any other locale. Still, there no reason to print weird character, no
matter what locale is and how broken it is.

Note You need to log in before you can comment on or make changes to this bug.