Bug 72542 - need Vojtech Pavlik's VIA updates for vt8233a southbridge support
Summary: need Vojtech Pavlik's VIA updates for vt8233a southbridge support
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: null
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL: http://www.andrew.cmu.edu/user/qralst...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-25 02:05 UTC by James Ralston
Modified: 2007-04-18 16:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-08 20:53:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Vojtech Pavlik's VIA updates, for 2.4.18-11 kernel (15.49 KB, patch)
2002-08-25 02:08 UTC, James Ralston
no flags Details | Diff

Description James Ralston 2002-08-25 02:05:57 UTC
Support for the VIA vt8233a southbridge didn't appear in the Linux kernel until
2.4.19-pre5, when Vojtech Pavlik updated drivers/ide/ide-timing.h and
drivers/ide/via82cxxx.c.

Although the Red Hat (null) beta kernel is based on 2.4.19-pre10-ac2, and should
thus contain support for the VIA vt8233a southbridge, the (null) kernel doesn't
support the vt8233a, because the linux-2.4.18-idebackport patch (patch 2390)
reverts Vojtech Pavlik's updates.
	
Since Red Hat Linux 7.3 (kernel-2.4.18-4), I've been building my own kernel
(based on Red Hat's) which includes Vojtech Pavlik's VIA southbridge updates. 
While I certainly can't test my kernel as thoroughly as Red Hat does, I've had
zero problems with my kernels.

Since I noticed other people were having the same problems with VIA vt8233a
southbridges, I documented what I'd discovered and done on my web page:

    http://www.andrew.cmu.edu/user/qralston/dev/

I'd like to see Vojtech Pavlik's VIA updates included in the official Red Hat
kernel.  Please consider adding them.

Comment 1 James Ralston 2002-08-25 02:08:32 UTC
Created attachment 72811 [details]
Vojtech Pavlik's VIA updates, for 2.4.18-11 kernel

Comment 2 Arjan van de Ven 2002-08-25 08:51:14 UTC
please run up2date before filing such bugs ;)

Comment 3 Matthew Hannigan 2002-08-25 14:39:23 UTC
What does it mean for it to be 'not supported'
I have installed 7.2, skipjack, 7,3,limbo and null on
my machine (gigabyte 7vrxp) without any problems.

No dma, but no problems either.  Is the lack of dma
the only problem?


Comment 4 Warren Togami 2002-09-08 20:53:05 UTC
Is this resolved in Rawhide?



Note You need to log in before you can comment on or make changes to this bug.