Bug 72558 - rpm install 100% complete and hangs... no rpm command work after
Summary: rpm install 100% complete and hangs... no rpm command work after
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-25 11:57 UTC by Martyn Russell
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-25 11:57:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martyn Russell 2002-08-25 11:57:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
After installing RPMs fine, I get to one and it installs to 100%, then it hangs.
 A normal kill will not kill the application, kill -9 is all that will.  Then
after it is killed, running any rpm command eg: rpm -qa just hangs.

Version-Release number of selected component (if applicable):
RPM version 4.1

How reproducible:
Couldn't Reproduce

Steps to Reproduce (from fresh installation of limbo):
1. Installed (with -ivh) apt-0.3.19cnc55-4sp_rh7x.i386.rpm /
apt-devel-0.3.19cnc55-4sp_rh7x.i386.rpm
2. Installed (with -ivh) gnet-1.0.4-2.src.rpm - which was empty ?? no rpm error
though
3. Therefore installed gnet-1.1.5-1.i386.rpm which is when the crash occured.
	

Expected Results:  RPM should have returned to the console prompt

Additional info:

This has happened to me twice, each on different machines.  Both machines were
AMDs.  Because I can't get RPM working afterwards I can't try to reproduce it. 
I have tried running rpmdb --rebuilddb to see if that would resolve the
situation, but it hangs again.

Comment 1 Jeff Johnson 2002-08-25 13:16:59 UTC
If you insist on doing "kill -9", you *will*
have stale locks that need to be removed by
	rm -f /var/lib/rpm/__db*

Erased packages were being removed when you typed
"kill -9". Yes there needs to be better feedback
for erased packages.


Note You need to log in before you can comment on or make changes to this bug.