Bug 72570 - make modules exit with an error trying to compile cipe
make modules exit with an error trying to compile cipe
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 13:58 EDT by Faisal Malallah
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 14:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Faisal Malallah 2002-08-25 13:58:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When trying to compile a kernel, during "make modules", the compiling will stop
with an error on cipe.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.make dep
2.make clean
3.make bzImage
4.make modules
	

Actual Results:
In file included from cipe.h:69,
                 from module.c:15:
/usr/src/linux-2.4.18-12.3/include/net/sock.h: In function `sk_filter_release':
/usr/src/linux-2.4.18-12.3/include/net/sock.h:934: warning: implicit declaration
of function `kfree_R037a0cba'
/usr/src/linux-2.4.18-12.3/include/net/sock.h: In function `sock_orphan':
/usr/src/linux-2.4.18-12.3/include/net/sock.h:1009: `do_softirq_Rf0a529b7'
undeclared (first use in this function)
/usr/src/linux-2.4.18-12.3/include/net/sock.h: In function `sock_graft':
/usr/src/linux-2.4.18-12.3/include/net/sock.h:1018: `do_softirq_Rf0a529b7'
undeclared (first use in this function)
/usr/src/linux-2.4.18-12.3/include/net/sock.h: In function `sock_recv_timestamp':
/usr/src/linux-2.4.18-12.3/include/net/sock.h:1266: warning: implicit
declaration of function `put_cmsg_Rf39bf4d9'
module.c: In function `cipe_check_kernel':
module.c:73: warning: implicit declaration of function `printk_R1b7d4074'
/usr/src/linux-2.4.18-12.3/include/linux/skbuff.h: In function `kunmap_skb_frag':
/usr/src/linux-2.4.18-12.3/include/linux/skbuff.h:1108: warning: asm operand 1
probably doesn't match constraints
make[3]: *** [module.o] Error 1
make[3]: Leaving directory `/usr/src/linux-2.4.18-12.3/drivers/addon/cipe'
make[2]: *** [_modsubdir_cipe] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.18-12.3/drivers/addon'
make[1]: *** [_modsubdir_addon] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-12.3/drivers'
make: *** [_mod_drivers] Error 2


Expected Results:  modules compile successfully

Additional info:

I tried kernel-2.4.18-12.3 from rawhide and it gave the same error
Comment 1 Arjan van de Ven 2002-08-25 15:04:07 EDT
what config are you using ?
Comment 2 Faisal Malallah 2002-08-25 18:19:32 EDT
I used the default .config that came with the kernel-source package. I just
added NTFS as a module.





Comment 3 Need Real Name 2002-11-20 08:42:18 EST
I am receiving the exact same error as listed above.  My 
installation/configuration is a Compaq DL360 running RH 8.0.  I have installed 
the kernel source rpm and just ran make menuconfig (no changes made), then make 
dep, and finally make modules and it errors out in the CIPE modules.

I have also attemtped to uncheck the CIPE module and run the make modules again 
and receive a similar error on a different module.
Comment 4 Arjan van de Ven 2002-11-20 08:46:51 EST
looks like a forgotten make mrproper 
Comment 5 Alan Cox 2003-06-05 14:42:23 EDT
NOTEXACTLYABUG is closer. This is something the 2.5 build system addresses

Note You need to log in before you can comment on or make changes to this bug.