Bug 72576 - up2date busy loops while downloading package
up2date busy loops while downloading package
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i686 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 15:28 EDT by Scott Lamb
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-31 23:34:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Lamb 2002-08-25 15:28:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
While downloading a package, up2date uses all the CPU time it can get. Seems
unnecessary - what could it be doing?

Version-Release number of selected component (if applicable):

up2date-2.9.46-1

How reproducible:
Always

Steps to Reproduce:
1. Run up2date and start a package download
2. Watch the System Monitor


Actual Results:  CPU load rises until it reaches 100% and stays there until the
package is downloaded

Expected Results:  CPU load stays fairly low - downloading is not intensive

Additional info:

Marked as low severity & priority - this doesn't stop me from doing anything,
just annoying.
Comment 1 Adrian Likins 2002-08-26 15:06:43 EDT
I'll take a look at it.

What kind of connection are you on?

package downloads are done via ssl, so can use
a fair amount of cpu on systems with fast
connections.
Comment 2 Scott Lamb 2002-08-26 16:10:36 EDT
That makes more sense. I do have a pretty modern system, though - the
processor's an Athlon 1GHz. Downloading over a cable modem, random guess is 150KB/s.
Comment 3 Mihai Ibanescu 2002-08-26 16:15:44 EDT
You may want to turn SSL off (just for kicks), and see if the load is still high
during package downloads. Let us know how it turns out.
Comment 4 Scott Lamb 2002-08-26 20:48:55 EDT
Okay, tried that - I toggled useNoSSLForPackages in /etc/sysconfig/rhn/up2date
and verified with tcpdump a lot of plain http packets were being sent around. It
still maxed out CPU usage.
Comment 5 Adrian Likins 2002-08-31 23:33:54 EDT
I belive this is fixed in rhnlib 0.9-1. 

(there was a bug where downloads were taking way too
much memory _and_ cpu). Too small of a buffer size
amongst other things. 
Comment 6 Scott Lamb 2002-09-07 14:16:10 EDT
Yep, I no longer see the problem.

Note You need to log in before you can comment on or make changes to this bug.