Bug 725870 - some subscription-manager list commands should not require that the system be registered
some subscription-manager list commands should not require that the system be...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Devan Goodwin
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-26 16:00 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-26 16:00:17 EDT
Description of problem:

Currently, the following subscription-manager list commands require that the consumer be registered...

# subscription-manager list
Error: You need to register this system by running `register` command before using this option.
# subscription-manager list --installed
Error: You need to register this system by running `register` command before using this option.
# subscription-manager list --consumed
Error: You need to register this system by running `register` command before using this option.

I believe this restriction should be lifted.
These are local client operations that should not need a connection to a candlepin server.  Remember that in the disconnected case, a client can import and consume an entitlement without ever being registered (from the client). Reference https://bugzilla.redhat.com/show_bug.cgi?id=712978#c7 



Version-Release number of selected component (if applicable):
# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.63.7bb4765.el6.x86_64
Comment 1 Devan Goodwin 2011-08-02 13:13:39 EDT
Agreed, should be lifted for --installed and --consumed. 

Fixed in subscription-manager.git: fd54aff43124b3de24746eccc9e6bf384cc10d2a
Comment 2 John Sefler 2011-08-02 16:16:11 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.80.a26379e.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager unregister
This system is currently not registered.

[root@jsefler-onprem-62server ~]# subscription-manager list
No installed Products to list
[root@jsefler-onprem-62server ~]# subscription-manager list --installed
No installed Products to list
[root@jsefler-onprem-62server ~]# subscription-manager list --consumed
No Consumed subscription pools to list
[root@jsefler-onprem-62server ~]# subscription-manager list --available
Error: You need to register this system by running `register` command before using this option.
[root@jsefler-onprem-62server ~]# subscription-manager list --available --all
Error: You need to register this system by running `register` command before using this option.
[root@jsefler-onprem-62server ~]# 

moving to VERIFIED
Comment 3 errata-xmlrpc 2011-12-06 12:22:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.