Bug 72591 - evolution-mail crashes while printing
evolution-mail crashes while printing
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-25 18:02 EDT by louisgtwo
Modified: 2008-05-01 11:38 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-09 21:49:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2002-08-25 18:02:35 EDT
while trying to print a .gif image send in an email evolution-mail crashes.
Attached is a backtrace log

Script started on Sun Aug 25 17:48:12 2002
louisg00@tiger:

[louisg00@tiger louisg00]$ 
[louisg00@tiger louisg00]$ 
[louisg00@tiger louisg00]$ g
[louisg00@tiger louisg00]$ g
[louisg00@tiger louisg00]$ gd
[louisg00@tiger louisg00]$ gd
[louisg00@tiger louisg00]$ gdb
[louisg00@tiger louisg00]$ gdb
[louisg00@tiger louisg00]$ gdb 
[louisg00@tiger louisg00]$ gdb 
[louisg00@tiger louisg00]$ gdb /
[louisg00@tiger louisg00]$ gdb /
[louisg00@tiger louisg00]$ gdb /u
[louisg00@tiger louisg00]$ gdb /u
[louisg00@tiger louisg00]$ gdb /us
[louisg00@tiger louisg00]$ gdb /us
[louisg00@tiger louisg00]$ gdb /usr
[louisg00@tiger louisg00]$ gdb /usr
[louisg00@tiger louisg00]$ gdb /usr/
[louisg00@tiger louisg00]$ gdb /usr/
[louisg00@tiger louisg00]$ gdb /usr/s
[louisg00@tiger louisg00]$ gdb /usr/s
[louisg00@tiger louisg00]$ gdb /usr/[K
[louisg00@tiger louisg00]$ gdb /usr/
[louisg00@tiger louisg00]$ gdb /usr/b
[louisg00@tiger louisg00]$ gdb /usr/b
[louisg00@tiger louisg00]$ gdb /usr/bi
[louisg00@tiger louisg00]$ gdb /usr/bi
[louisg00@tiger louisg00]$ gdb /usr/bin
[louisg00@tiger louisg00]$ gdb /usr/bin
[louisg00@tiger louisg00]$ gdb /usr/bin/
[louisg00@tiger louisg00]$ gdb /usr/bin/
[louisg00@tiger louisg00]$ gdb /usr/bin/e
[louisg00@tiger louisg00]$ gdb /usr/bin/e
[louisg00@tiger louisg00]$ gdb /usr/bin/ev
[louisg00@tiger louisg00]$ gdb /usr/bin/ev
[louisg00@tiger louisg00]$ gdb /usr/bin/evo
[louisg00@tiger louisg00]$ gdb /usr/bin/evo
[louisg00@tiger louisg00]$ gdb /usr/bin/evol
[louisg00@tiger louisg00]$ gdb /usr/bin/evol
[louisg00@tiger louisg00]$ gdb /usr/bin/evolu
[louisg00@tiger louisg00]$ gdb /usr/bin/evolu
[louisg00@tiger louisg00]$ gdb /usr/bin/evolut
[louisg00@tiger louisg00]$ gdb /usr/bin/evolut
[louisg00@tiger louisg00]$ gdb /usr/bin/evoluti
[louisg00@tiger louisg00]$ gdb /usr/bin/evoluti
[louisg00@tiger louisg00]$ gdb /usr/bin/evolutio
[louisg00@tiger louisg00]$ gdb /usr/bin/evolutio
[louisg00@tiger louisg00]$ gdb /usr/bin/evolution
[louisg00@tiger louisg00]$ gdb /usr/bin/evolution

GNU gdb Red Hat Linux (5.2.1-2)

Copyright 2002 Free Software Foundation, Inc.

GDB is free software, covered by the GNU General Public License, and you are

welcome to change it and/or distribute copies of it under certain conditions.

Type "show copying" to see the conditions.

There is absolutely no warranty for GDB.  Type "show warranty" for details.

This GDB was configured as "i386-redhat-linux"...

(no debugging symbols found)...

(gdb) run

Starting program: /usr/bin/evolution 

[New Thread 1024 (LWP 2636)]



Program received signal SIGPIPE, Broken pipe.

[Switching to Thread 1024 (LWP 2636)]

0x420c4f2d in writev () from /lib/i686/libc.so.6

(gdb) bt

#0  0x420c4f2d in writev () from /lib/i686/libc.so.6

#1  0x4037d757 in giop_send_buffer_write () from /usr/lib/libIIOP.so.0

#2  0x402ce75d in Bonobo_Control_unrealize () from /usr/lib/libbonobo.so.2

#3  0x403b82a3 in bonobo_control_frame_sync_unrealize ()

   from /usr/lib/libbonobox.so.2

#4  0x403c2982 in bonobo_socket_unrealize () from /usr/lib/libbonobox.so.2

#5  0x40b6a4d6 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0

#6  0x40ba5ece in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#7  0x40ba34ae in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#8  0x40be5fbb in gtk_widget_unrealize () from /usr/lib/libgtk-1.2.so.0

#9  0x40be4a12 in gtk_widget_unparent () from /usr/lib/libgtk-1.2.so.0

#10 0x40aef1ce in gtk_box_remove () from /usr/lib/libgtk-1.2.so.0

#11 0x40b6a330 in gtk_marshal_NONE__POINTER () from /usr/lib/libgtk-1.2.so.0

#12 0x40ba5ece in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#13 0x40ba34ae in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#14 0x40b18201 in gtk_container_remove () from /usr/lib/libgtk-1.2.so.0

#15 0x40bee744 in gtk_widget_shutdown () from /usr/lib/libgtk-1.2.so.0

#16 0x40b810dc in gtk_object_destroy () from /usr/lib/libgtk-1.2.so.0

#17 0x40be4d29 in gtk_widget_destroy () from /usr/lib/libgtk-1.2.so.0

#18 0x403c36fd in bonobo_socket_filter_func () from /usr/lib/libbonobox.so.2

#19 0x40c32158 in gdk_event_apply_filters () from /usr/lib/libgdk-1.2.so.0

#20 0x40c32efd in gdk_event_translate () from /usr/lib/libgdk-1.2.so.0

#21 0x40c3304b in gdk_events_queue () from /usr/lib/libgdk-1.2.so.0

---Type <return> to continue, or q <return> to quit---

#22 0x40c33274 in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0

#23 0x40dcd97e in g_main_dispatch () from /usr/lib/libglib-1.2.so.0

#24 0x40dcde59 in g_main_iterate () from /usr/lib/libglib-1.2.so.0

#25 0x40dce0f4 in g_main_run () from /usr/lib/libglib-1.2.so.0

#26 0x40b686df in gtk_main () from /usr/lib/libgtk-1.2.so.0

#27 0x402ed99e in bonobo_main () from /usr/lib/libbonobo.so.2

#28 0x0808fad6 in main ()

#29 0x420155c4 in __libc_start_main () from /lib/i686/libc.so.6

(gdb) thread 1

[Switching to thread 1 (Thread 1024 (LWP 2636))]#0  0x420c4f2d in writev ()

   from /lib/i686/libc.so.6

(gdb) bt

#0  0x420c4f2d in writev () from /lib/i686/libc.so.6

#1  0x4037d757 in giop_send_buffer_write () from /usr/lib/libIIOP.so.0

#2  0x402ce75d in Bonobo_Control_unrealize () from /usr/lib/libbonobo.so.2

#3  0x403b82a3 in bonobo_control_frame_sync_unrealize ()

   from /usr/lib/libbonobox.so.2

#4  0x403c2982 in bonobo_socket_unrealize () from /usr/lib/libbonobox.so.2

#5  0x40b6a4d6 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0

#6  0x40ba5ece in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#7  0x40ba34ae in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#8  0x40be5fbb in gtk_widget_unrealize () from /usr/lib/libgtk-1.2.so.0

#9  0x40be4a12 in gtk_widget_unparent () from /usr/lib/libgtk-1.2.so.0

#10 0x40aef1ce in gtk_box_remove () from /usr/lib/libgtk-1.2.so.0

#11 0x40b6a330 in gtk_marshal_NONE__POINTER() from /usr/lib/libgtk-1.2.so.0

#12 0x40ba5ece in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0

#13 0x40ba34ae in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0

#14 0x40b18201 in gtk_container_remove () from /usr/lib/libgtk-1.2.so.0

#15 0x40bee744 in gtk_widget_shutdown () from /usr/lib/libgtk-1.2.so.0

#16 0x40b810dc in gtk_object_destroy () from /usr/lib/libgtk-1.2.so.0

#17 0x40be4d29 in gtk_widget_destroy () from /usr/lib/libgtk-1.2.so.0

#18 0x403c36fd in bonobo_socket_filter_func () from /usr/lib/libbonobox.so.2

#19 0x40c32158 in gdk_event_apply_filters () from /usr/lib/libgdk-1.2.so.0

#20 0x40c32efd in gdk_event_translate () from /usr/lib/libgdk-1.2.so.0

#21 0x40c3304b in gdk_events_queue () from /usr/lib/libgdk-1.2.so.0

---Type <return> to continue, or q <return> to quit---

#22 0x40c33274 in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0

#23 0x40dcd97e in g_main_dispatch () from /usr/lib/libglib-1.2.so.0

#24 0x40dcde59 in g_main_iterate () from /usr/lib/libglib-1.2.so.0

#25 0x40dce0f4 in g_main_run () from /usr/lib/libglib-1.2.so.0

#26 0x40b686df in gtk_main () from /usr/lib/libgtk-1.2.so.0

#27 0x402ed99e in bonobo_main () from /usr/lib/libbonobo.so.2

#28 0x0808fad6 in main ()

#29 0x420155c4 in __libc_start_main () from /lib/i686/libc.so.6

(gdb) thread 2

Thread ID 2 not known.

(gdb) quit

The program is running.  Exit anyway? (y or n) y

[louisg00@tiger louisg00]$ 
Script done on Sun Aug 25 17:53:24 2002
Comment 1 Jeremy Katz 2002-08-29 00:55:15 EDT
Is it only when trying to print gifs?  If so, does installing gdk-pixbuf from
rawhide help?
Comment 2 louisgtwo 2002-08-29 21:14:47 EDT
Just upgraded null with up2date which contains same version of gdk-pixbuf as
rawhide and problem still exists. The evolution-mail component crashes while
printing one email after another in a row, not just .gifs.
Comment 3 James Keeble 2002-11-19 13:59:04 EST
I've found that printing plain-text messages works OK, however when I try to
print an HTML message, the evolution mail component crashes.  If I've tried to
print the HTML message to a file, the file is created, but has zero length.
Comment 4 Tom Cross 2002-12-06 11:56:38 EST
I will have to add two "ME-TOO"s to this list.  A user here had trouble with
evolution printing his messages.  The evolution-mail component would crash every
time he tried to print it.  I figured it was user error.

Now I find that when I try to print certain HTML messages, evolution-mail will
crash 100% of the time.  They aren't overly-complicated messages either. 
Doesn't appear to be happening on our RedHat 7.2/7.3 with Ximian GNOME and
Ximian evolution 1.0.8, just with RedHat 8.0 with RH's evolution 1.0.8.
Comment 5 ingvar 2002-12-10 01:28:01 EST
I'm not sure if it has any value, but "AOL". I can't print HTML messages
neither. Evolution Mail dies screaming with a segfault. See Ximian Bugzilla, bug
#31551, http://bugzilla.ximian.com/show_bug.cgi?id=31551

I'd like to quote Mark Gordon of Ximian:

------- Additional Comments From Mark Gordon 2002-11-27 15:13 -------

This crash is due to a bug in gnome-print 0.35, which shipped with Red
Hat Linux 8.0.  Ximian has released gnome-print/libgnomeprint15 0.37
packages which include the fix to this crasher, so Ximian users who
have updated through Red Carpet will not see this bug any more.  I
suspect many of these reports are from users with stock Red Hat Linux
8.0 systems, though.  Anyone who wants to see this fixed but would
prefer packages from Red Hat rather than Ximian should see the URL for
Red Hat's bug above and pester accordingly. ;-)

And here's Gnome Bugzilla's comments of the bug:
http://bugzilla.gnome.org/show_bug.cgi?id=97170

Any chances we'll get native RedHat packages that fix this problem?

Ingvar

Comment 6 ghopper 2002-12-10 16:38:25 EST
I get the same crash (segmentation fault) EVERY time I try to print an email.

After clicking to close that window, I get another one that says: "The Evolution
component that handles folders of the type "mail" has unexpectedly quit.  You
will need to quit Evolution and restart in order to access that data again."

I am using Evolution 1.2 downloaded with Red Carpet, and I run up2date every
time I am prompted.  I am using the KDE desktop in RH8.  It doesn't matter what
the email is -- plain text or html, with or without attachments.  Very frustrating.
Comment 7 G.F. Duivesteijn 2002-12-16 05:19:30 EST
Here at the university, we all experience this bug (RH 8.0, evolution 1.0.8).
Printing of an HTML email crashes evolution. I really hope this problem will be
solved in the near future.

Gilbert
Comment 8 ingvar 2002-12-16 13:09:33 EST
For those who have no time to wait for RedHat, and want to upgrade as little as
possible to none-redhat-packages; The gnome-print-packages from Ximian fixes
this, as stated earlier.

You'll need to install the following packages:

gnome-print-0.37-2.ximian.1.i386.rpm
libgnomeprint15-0.37-2.ximian.1.i386.rpm

and possibly
gnome-print-devel-0.37-2.ximian.1.i386.rpm 

These are availble at ftp://ftp.ximian.com/pub/ximian-gnome/redhat-80-i386/

Ingvar
Comment 9 Jeremy Katz 2003-02-09 21:49:30 EST
Newer gnome-print is available in rawhide.

Note You need to log in before you can comment on or make changes to this bug.