This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 726007 - Broken upgrade path
Broken upgrade path
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cogl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-27 06:02 EDT by Nicolas Mailhot
Modified: 2011-08-10 04:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-10 04:12:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2011-07-27 06:02:41 EDT
#  yum update  -x xorg-x11-drv-ati -x netbeans-platform.x86_64
Loaded plugins: downloadonly, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package clutter.x86_64 0:1.7.4-1.fc16 will be updated
---> Package clutter.x86_64 0:1.7.6-1.fc16 will be an update
---> Package clutter-gtk.x86_64 0:1.0.0-1.fc16 will be updated
---> Package clutter-gtk.x86_64 0:1.0.2-1.fc16 will be an update
--> Processing Dependency: libcogl.so.1()(64bit) for package: clutter-gtk-1.0.2-1.fc16.x86_64
---> Package cogl.x86_64 0:1.7.2-1.fc16 will be updated
--> Processing Dependency: libcogl.so.1()(64bit) for package: mutter-3.1.3.1-2.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: clutter-gtk-1.0.2-1.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: 1:cheese-libs-3.0.2-1.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: gnome-shell-3.1.3-2.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: empathy-3.1.3-4.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: 1:cheese-3.0.2-1.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: gnome-shell-3.1.3-2.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: empathy-3.1.3-4.fc16.x86_64
--> Processing Dependency: libcogl.so.1()(64bit) for package: clutter-gtk-1.0.2-1.fc16.x86_64
---> Package cogl.x86_64 0:1.7.4-1.fc16 will be an update
---> Package empathy.x86_64 0:3.1.3-2.fc16 will be updated
---> Package empathy.x86_64 0:3.1.3-4.fc16 will be an update
---> Package evolution.x86_64 0:3.1.3-1.fc16 will be updated
---> Package evolution.x86_64 0:3.1.4-1.fc16 will be an update
---> Package evolution-NetworkManager.x86_64 0:3.1.3-1.fc16 will be updated
---> Package evolution-NetworkManager.x86_64 0:3.1.4-1.fc16 will be an update
---> Package evolution-data-server.x86_64 0:3.1.3-1.fc16 will be updated
--> Processing Dependency: libcamel-1.2.so.27()(64bit) for package: giggle-0.5-7.fc16.x86_64
---> Package evolution-data-server.x86_64 0:3.1.4-1.fc16 will be an update
---> Package evolution-help.noarch 0:3.1.3-1.fc16 will be updated
---> Package evolution-help.noarch 0:3.1.4-1.fc16 will be an update
---> Package gnome-panel.x86_64 0:3.0.2-2.fc16 will be updated
---> Package gnome-panel.x86_64 0:3.0.2-3.fc16 will be an update
---> Package gnome-panel-libs.x86_64 0:3.0.2-2.fc16 will be updated
---> Package gnome-panel-libs.x86_64 0:3.0.2-3.fc16 will be an update
---> Package gnome-shell.x86_64 0:3.1.3-1.fc16 will be updated
---> Package gnome-shell.x86_64 0:3.1.3-2.fc16 will be an update
--> Finished Dependency Resolution
Error: Package: clutter-gtk-1.0.2-1.fc16.x86_64 (koji-rawhide-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: empathy-3.1.3-4.fc16.x86_64 (koji-f16-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: empathy-3.1.3-4.fc16.x86_64 (koji-rawhide-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: 1:cheese-3.0.2-1.fc16.x86_64 (@koji-f16-builds/16)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: mutter-3.1.3.1-2.fc16.x86_64 (@koji-f16-builds/16)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: giggle-0.5-7.fc16.x86_64 (@koji-f16-builds)
           Requires: libcamel-1.2.so.27()(64bit)
           Removing: evolution-data-server-3.1.3-1.fc16.x86_64 (@koji-f16-builds/16)
               libcamel-1.2.so.27()(64bit)
           Updated By: evolution-data-server-3.1.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: 1:cheese-libs-3.0.2-1.fc16.x86_64 (@koji-f16-builds/16)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: gnome-shell-3.1.3-2.fc16.x86_64 (koji-f16-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: clutter-gtk-1.0.2-1.fc16.x86_64 (koji-f16-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
Error: Package: gnome-shell-3.1.3-2.fc16.x86_64 (koji-rawhide-builds)
           Requires: libcogl.so.1()(64bit)
           Removing: cogl-1.7.2-1.fc16.x86_64 (@koji-f16-builds/16)
               libcogl.so.1()(64bit)
           Updated By: cogl-1.7.4-1.fc16.x86_64 (koji-f16-builds)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Mads Kiilerich 2011-08-04 10:08:57 EDT
AFAICS: cogl was updated and changed so version just before f16 was branched, and a number of package dependencies thus broke:

# yum list $(repoquery --whatrequires 'libcogl.so.1()(64bit)')
Loaded plugins: langpacks, presto, refresh-packagekit
Available Packages
cheese.x86_64                              1:3.0.2-1.fc16       fedora
cheese-libs.x86_64                         1:3.0.2-1.fc16       fedora
claws-mail-plugins-geolocation.x86_64      3.7.9-7.fc16         fedora
clutter-gtk.x86_64                         1.0.2-1.fc16         fedora
ease.x86_64                                0.4-5.fc16           fedora
empathy.x86_64                             3.1.3-4.fc16         fedora
eog-plugins.x86_64                         3.1.2-1.fc16         fedora
gnome-games-extra.x86_64                   1:3.1.3-1.fc16       fedora
gnome-shell.x86_64                         3.1.3-2.fc16         fedora
mutter.x86_64                              3.1.3.1-2.fc16       fedora
mutter-devel.x86_64                        3.1.3.1-2.fc16       fedora
sushi.x86_64                               0.0.4-1.fc16         fedora

These packages have been updated and are now in updates-testing:

# yum list $(repoquery --whatrequires 'libcogl.so.2()(64bit)')
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
cheese.x86_64                   1:3.0.2-2.fc16        @updates-testing
cheese-libs.x86_64              1:3.0.2-2.fc16        @updates-testing
clutter.x86_64                  1.7.6-1.fc16          @fedora         
clutter-gtk.x86_64              1.0.2-2.fc16          @updates-testing
empathy.x86_64                  3.1.4-1.fc16          @updates-testing
gnome-shell.x86_64              3.1.4-1.fc16          @updates-testing
mutter.x86_64                   3.1.4-1.fc16          @updates-testing
sushi.x86_64                    0.0.5-1.fc16          @updates-testing
Available Packages
cogl-devel.x86_64               1.7.4-1.fc16          fedora          
ease.x86_64                     0.4-6.fc16            updates-testing 
eog-plugins.x86_64              3.1.2-2.fc16          updates-testing 
gnome-games-extra.x86_64        1:3.1.4-2.fc16        updates-testing 
mutter-devel.x86_64             3.1.4-1.fc16          updates-testing 

There is thus no cogl bug (perhaps except that the timing of the update could have been a bit better). Everything will be fine soon.
Comment 2 Peter Robinson 2011-08-10 04:12:50 EDT
this is now resolved. It was caused by the packages being built just before the branch.

Note You need to log in before you can comment on or make changes to this bug.