Bug 726135 - boards.txt should be a configuration file
Summary: boards.txt should be a configuration file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: arduino
Version: 14
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Oliver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-27 16:14 UTC by Bernard Johnson
Modified: 2011-10-05 17:36 UTC (History)
1 user (show)

Fixed In Version: arduino-0022-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-05 17:36:49 UTC
Type: ---


Attachments (Terms of Use)

Description Bernard Johnson 2011-07-27 16:14:51 UTC
Description of problem:
/usr/share/arduino/hardware/arduino/boards.txt should be a configuration (%config) file.  If the arduino code can not be easily made to look in /etc/arduino, maybe this should be installed as a symlink to /etc/arduino/boards.txt.

Arduino package upgrades cause this file to be nuked and it may contain user data (for other boards).


Version-Release number of selected component (if applicable):
arduino-0021-3.fc14.noarch

How reproducible:
Always

Actual results:
boards.txt overwritten on arduino package upgrade

Expected results:
boards.txt preserved

Additional info:
I marked this as medium severity due to the possibility of losing user data.

Comment 1 Peter Oliver 2011-09-12 21:29:17 UTC
Will be fixed in next release.

Comment 2 Fedora Update System 2011-09-18 20:18:22 UTC
arduino-0022-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/arduino-0022-5.fc16

Comment 3 Fedora Update System 2011-09-19 18:29:33 UTC
Package arduino-0022-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing arduino-0022-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/arduino-0022-5.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-10-05 17:36:43 UTC
arduino-0022-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.