Bug 72623 - Mozilla and Galeon drop shadows of cursor when scrolling through a text box.
Mozilla and Galeon drop shadows of cursor when scrolling through a text box.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks: 82784
  Show dependency treegraph
 
Reported: 2002-08-26 01:44 EDT by Shane R. Stixrud
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 19:20:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane R. Stixrud 2002-08-26 01:44:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
When using Galeon or Mozilla I have a video problem where the cursor will drop 
pixels.  If I load up www.google.com, type in a search string then left and 
right cursor through the text box I will get ghost cursors 
wherever my cursor "was".  I don't know if this problem is isolated to my 
video card or if its common to all X configurations, I will test this further 
Monday on my dell server.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Load Mozilla
2.go to www.google.com
3.type something into the search feild and left/right cursor through the text.
	

Actual Results:  Shadows of the cursor is dropped wherever it _WAS_.

Expected Results:  No dropped pixels

Additional info:
Comment 1 Christopher Blizzard 2002-08-26 07:31:52 EDT
Do they go away eventually?
Comment 2 Shane R. Stixrud 2002-08-26 12:49:45 EDT
If highlight the text with my mouse the pixels correct themselves.  I also 
noticed that this happens in the URL feild of Mozilla but does not occure in 
the URL feild of Galeon.  Perhaps it is a problem with Gecko's GTK support??
Comment 3 Shane R. Stixrud 2002-08-28 12:39:50 EDT
Some additional information.  This problem is _NOT_ resolved by installing
Mozilla 1.1.  I do not have this problem on my Dell Power Edge servers which use
an ATI chipset vs nvidia.
Comment 4 Christopher Blizzard 2002-08-28 13:25:47 EDT
Sounds like an mharris special!
Comment 5 Shane R. Stixrud 2002-09-03 12:12:47 EDT
Someone provided me with a workaround for this problem, I have not yet tested 
it however.

Workaround: put this in the "Screen" section of /etc/X11/XF86Config:
        Option "XaaNoSolidFillRect" "true"
Comment 6 Shane R. Stixrud 2002-09-03 21:56:32 EDT
I tested this workaround and it fixed the problem!  Any chance that either this
workaround a or fix will make it in before the final?  Here is my lspci info:

01:00.0 VGA compatible controller: nVidia Corporation NV20 [GeForce3] (rev a3)
Comment 7 Mike A. Harris 2002-09-21 06:23:34 EDT
Yes, I can add that workaround to the hardware database.  Can you
provide me with:  lspci -vn

I need the ID's in order to make the proper changes.

Thanks.
Comment 8 Shane R. Stixrud 2002-09-22 18:31:34 EDT
Here ya go, seeing as the new release is right around the corner, is there any
chance that this will make it in before release?

00:00.0 Class 0600: 1106:3099
        Subsystem: 1043:8064
        Flags: bus master, medium devsel, latency 0
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

00:01.0 Class 0604: 1106:b099
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: f2000000-f35fffff
        Prefetchable memory behind bridge: f3700000-f7ffffff
        Capabilities: [80] Power Management version 2

00:06.0 Class 0180: 105a:0d30 (rev 02)
        Subsystem: 105a:4d33
        Flags: bus master, medium devsel, latency 32, IRQ 14
        I/O ports at d800 [size=8]
        I/O ports at d400 [size=4]
        I/O ports at d000 [size=8]
        I/O ports at b800 [size=4]
        I/O ports at b400 [size=64]
        Memory at f1800000 (32-bit, non-prefetchable) [size=128K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [58] Power Management version 1

00:0d.0 Class 0401: 1102:0002 (rev 07)
        Subsystem: 1102:8061
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at b000 [size=32]
        Capabilities: [dc] Power Management version 1

00:0d.1 Class 0980: 1102:7002 (rev 07)
        Subsystem: 1102:0020
        Flags: bus master, medium devsel, latency 32
        I/O ports at a800 [disabled] [size=8]
        Capabilities: [dc] Power Management version 1

00:0e.0 Class 0200: 10b7:9055 (rev 24)
        Subsystem: 10b7:9055
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at a400 [size=128]
        Memory at f1000000 (32-bit, non-prefetchable) [size=128]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [dc] Power Management version 1

00:11.0 Class 0601: 1106:3074
        Subsystem: 1043:8052
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2

00:11.1 Class 0101: 1106:0571 (rev 06) (prog-if 8a [Master SecP PriP])
        Flags: bus master, stepping, medium devsel, latency 32, IRQ 11
        I/O ports at a000 [size=16]
        Capabilities: [c0] Power Management version 2

00:11.2 Class 0c03: 1106:3038 (rev 1b)
        Subsystem: 0925:1234
        Flags: bus master, medium devsel, latency 32, IRQ 14
        I/O ports at 9800 [size=32]
        Capabilities: [80] Power Management version 2

00:11.3 Class 0c03: 1106:3038 (rev 1b)
        Subsystem: 0925:1234
        Flags: bus master, medium devsel, latency 32, IRQ 14
        I/O ports at 9400 [size=32]
        Capabilities: [80] Power Management version 2

00:11.4 Class 0c03: 1106:3038 (rev 1b)
        Subsystem: 0925:1234
        Flags: bus master, medium devsel, latency 32, IRQ 14
        I/O ports at 9000 [size=32]
        Capabilities: [80] Power Management version 2

01:00.0 Class 0300: 10de:0200 (rev a3)
        Subsystem: 1043:402f
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at f4000000 (32-bit, prefetchable) [size=64M]
        Memory at f3800000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at f37f0000 [disabled] [size=64K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0
Comment 9 Mike A. Harris 2003-04-12 12:20:30 EDT
Please test this video card with Red Hat Linux 9 and indicate here if
the problem is resolved or not.

If the problem persists, please file a bug report at http://bugs.xfree86.org
which will get to the nv driver maintainer whom works at Nvidia, and add a
link to the URL of your upstream bug report so I can track the issue
upstream and backport any fixes that get made by the maintainer.
 
Thanks.
Comment 10 Mike A. Harris 2004-08-30 19:20:29 EDT
Assuming the bug no longer occurs in Fedora Core 2, closing as
RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.