This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 726292 - Unable to turn IME on with Release+something
Unable to turn IME on with Release+something
Status: CLOSED DUPLICATE of bug 725494
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 00:55 EDT by Akira TAGOH
Modified: 2011-07-28 22:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-28 07:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2011-07-28 00:55:16 EDT
Description of problem:
When grubbing keys to setup the trigger key, ibus gives Release+something if no modifiers are pressed though, it doesn't function at all.

Version-Release number of selected component (if applicable):
ibus-1.3.99.20110419-12.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1.run ibus-setup
2.click ... button on General->Keyboard Shortcuts->Enable or disable
3.click ... button on Keycode to grub the key
4.press something without modifiers keys such as Zenkaku_Hankaku
  
Actual results:
resulting Release+Zenkaku_Hankaku though, pressing Zenkaku_Hankaku doesn't enable IM.

Expected results:
should works correctly

Additional info:
Getting rid of "release" checkbox simply works.
Comment 1 fujiwara 2011-07-28 07:27:02 EDT
Probably I think this is duplicated of bug 725494.
Release+Zenkaku_Hankaku could work fine in my env if I would modify ibus-anthy compose file.

The Release is needed to distinguish Alt+another_modifier and Alt only.

*** This bug has been marked as a duplicate of bug 725494 ***
Comment 2 Akira TAGOH 2011-07-28 08:05:58 EDT
I'm not sure what exactly the compose file is, but I can see this issue on mozc too.
Comment 3 fujiwara 2011-07-28 22:13:28 EDT
(In reply to comment #2)
> I'm not sure what exactly the compose file is, but I can see this issue on mozc
> too.

If you can reproduce your problem even though ibus-anthy is uninstalled, probably I cannot reproduce your problem.
I mean if ibus-anthy is listed on the ibus preloaded engines, the problem can be happened even though ibus-mozic is the primary ibus engine.
You may need to restart ibus-daemon with 'ibus-daemon -x -r -t refresh' if $HOME/.cache/ibus/bus/registry.xml is old.

Note You need to log in before you can comment on or make changes to this bug.