Bug 726313 - disable dhcpd ,but after reboot ,dhcpd also started
disable dhcpd ,but after reboot ,dhcpd also started
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-28 03:52 EDT by frank ling
Modified: 2012-04-02 06:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 06:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description frank ling 2011-07-28 03:52:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. /bin/systemctl disable dhcpd.service
2. reboot
3. ps -ef | grep dhcpd
  
Actual results:
have dhcpd process

Expected results:
no dhcpd process

Additional info:
Comment 1 frank ling 2011-07-29 05:21:55 EDT
i think maybe 
/etc/NetworkManager/dispatcher.d/12-dhcp have error
Comment 2 Jiri Popelka 2011-08-11 10:20:57 EDT
(In reply to comment #1)
> i think maybe 
> /etc/NetworkManager/dispatcher.d/12-dhcp have error

Thanks for the report, however it works for me.

There was a bug #699027 in systemd when systemctl reported service as enabled while it was disabled. But this problem should be fixed already.

What does 'rpm -q systemd' say ?

And what show these commands:
 systemctl disable dhcpd.service; echo $?
 systemctl is-enabled dhcpd.service; echo $?
Comment 3 Jiri Popelka 2012-04-02 06:14:10 EDT
I'm closing this ticket because it has not been updated by the submitter for almost 8 months. If the issue still requires resolution, please re-open.

Note You need to log in before you can comment on or make changes to this bug.