Bug 726455 - (EAP 5.1.x admin-console) PC should only ask discovery components for additional classpath URLs (i.e. client jars) if per-resource classloaders are enabled in the plugin container config
(EAP 5.1.x admin-console) PC should only ask discovery components for additio...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 5
Classification: JBoss
Component: jbossas (Show other bugs)
5.1.0
All All
medium Severity medium
: ---
: ---
Assigned To: Jan Martiska
Jakub Cechacek
:
Depends On: 635835
Blocks: 725852
  Show dependency treegraph
 
Reported: 2011-07-28 12:54 EDT by Ian Springer
Modified: 2015-02-01 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 635835
Environment:
Last Closed: 2015-01-05 07:25:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2011-07-28 12:54:39 EDT
+++ This bug was initially created as a clone of Bug #635835 +++

Otherwise, the plugin is doing unnecessary work, since the PC won't use the list of jars returned for anything anyway.

--- Additional comment from ian.springer@redhat.com on 2010-09-20 16:35:11 EDT ---

Fixed in master (commit 594c686) and release-3.0.0 (commit 0a244b7).

--- Additional comment from mfoley@redhat.com on 2011-06-29 16:23:50 EDT ---

discussed with ips.  impossible to verify without attaching a debugger. the only case where per-res classloaders would not be enabled would be when the pc is running in the admin-console. no regressions there, or in other plugins.
Comment 1 Ian Springer 2011-08-09 16:25:32 EDT
Fixed in the AdminConsole_EAP_5_1 branch - commit f1bb1cc.
Comment 3 Jan Martiska 2015-01-05 07:25:15 EST
This has been fixed long ago, cleaning up.

Note You need to log in before you can comment on or make changes to this bug.