Bug 726575 - Cannot <xref> between books in a <set>
Cannot <xref> between books in a <set>
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Jeff Fearn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-29 00:47 EDT by Rebecca Newton
Modified: 2011-08-24 22:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-24 22:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rebecca Newton 2011-07-29 00:47:40 EDT
Description of problem: 

<xi:include>s work fine between books in a set but <xref>s don't. Just doing the <xref> normally, like this:

<xref linkend="sect-your-mother-was-a-hamster-"/>

Publican just can't see it, the same as normal when there's no corresponding section in your book.

If you specify the direct path, like when <xi:include>ing, like this:

<xref linkend="../../The_Holy_Grail/en-US/sect-your-mother-was-a-hamster"/>

You get validation errors, AND the usual I Can't See It error.

I've also tried specifying the chapter.xml as well, and the path without escaping two dirs.

Version-Release number of selected component (if applicable):


How reproducible:
Create two books in a standalone set and try to <xref> to a section in the other book.

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
Errors described above.

Expected results:
<xref> are valid between books.

Additional info:
Comment 1 Jeff Fearn 2011-07-29 01:06:08 EDT
At a guess I think you are hitting the forced run of clean_ids that publican does to avoid id clashes when building sets.

To confirm, try running:

$ grep -r 'id-that-you-want' tmp/en-US/xml/*

If that's it then you could try running clean_ids before you build to see if that works.
Comment 2 Jeff Fearn 2011-08-23 18:53:19 EDT
Can you supply the repo location for this set? It'll make testing easier.
Comment 3 Rebecca Newton 2011-08-23 19:26:42 EDT
Hey Jeff, the source is here: https://svn.devel.redhat.com/repos/ecs/JBoss_Web_Framework_Kit/trunk/2.0/RichFaces_Developer_Guide/ I discovered that <xi:include>s won't work either, not sure why I thought they did. I don't know if this is related. 

I did try running publican clean for the <xref> stuff but it took a few hours so I kept having to give up.
Comment 4 Rebecca Newton 2011-08-24 22:05:07 EDT
Turns out, if you follow the instructions in the Publican UG properly ... stuff works ;) I fixed the format of the set so that it wasn't books inside the set, and that has fixed both the <xi:include> and <xref> issues. Thanks for your time, Jeff.

Note You need to log in before you can comment on or make changes to this bug.