Bug 72674 - package can not be build from sources
package can not be build from sources
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: libgal7 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
package can not be build from sources
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 11:46 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 12:01:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-26 11:46:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I've tried to build package. During compilation files from the 
directory "BUILD/gal-0.8/gal/e-text" I receive multipl compiler errors with the 
next message:
gdk-pixbuf/gdk-pixbuf.h: No such file or directory

I see that the command line for compilation of the first file from this 
directory is the next:
gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I/usr/include/gnome-1.0 -
DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/glib-1.2 -
I/usr/lib/glib/include -I/usr/include/orbit-1.0 -I/usr/include/gtk-1.2 -
I/usr/X11R6/include -DG_LOG_DOMAIN=\"e-text\" -I/usr/include/gtk-1.2 -
I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -O2 -
march=i386 -mcpu=i686 -Wall -Wunused -c e-entry.c  -fPIC -DPIC -o .libs/e-
entry.lo

The error is due to the absence of the next option "-I/usr/include/gdk-pixbuf-
1.0". Header "gdk-pixbuf/gdk-pixbuf.h" is plased in the 
directory /usr/include/gdk-pixbuf-1.0.


I made workaround:
 added option -I/usr/include/gdk-pixbuf-1.0 to command line, if nessesary.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Unpack kde1-compat-1~2-11.src.rpm to some local dir
2.Build sources (rpm -bc kde1-compat.spec)

	

Additional info:
Comment 1 Need Real Name 2002-08-26 11:56:50 EDT
Steps to Reproduce:
1.Unpack libgal7-0.8-7.src.rpmto some local dir
2.Build sources (rpm -bc libgal7.spec)

Comment 2 Havoc Pennington 2002-08-27 18:34:18 EDT
The problem fwiw is that gdk-pixbuf-config --cflags output needs to be included
in the cflags in the gal makefile.

We would not normally release an errata for this, and libgal7 is not present in
the next release, so closing the bug.

Note You need to log in before you can comment on or make changes to this bug.