Bug 72681 - snmpd handles get-next poorly
snmpd handles get-next poorly
Status: CLOSED DUPLICATE of bug 60161
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 12:37 EDT by l0cksley
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-26 12:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from /var/log/messages (3.66 KB, text/plain)
2002-08-26 12:40 EDT, l0cksley
no flags Details

  None (edit)
Description l0cksley 2002-08-26 12:37:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
With the default configuration which restricts access
to the system branch only, issuing a get-next at the
end of the branch causes snmpd to spew modprobe and
/proc/stat messages in /var/log/messages,
use 100% CPU and stop responding for several minutes.
This does not occur with looser access restrictions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. snmpgetnext localhost public .1.3.6.1.2.1.1.9.1.4.9
2.
3.
	

Actual Results:  Timeout: No Response from localhost

Expected Results:  End of MIB

Additional info:

ucd-snmp-4.2.5-7.73.0
Comment 1 l0cksley 2002-08-26 12:40:26 EDT
Created attachment 73064 [details]
Excerpt from /var/log/messages
Comment 2 Phil Knirsch 2002-08-28 09:45:37 EDT

*** This bug has been marked as a duplicate of 60161 ***

Note You need to log in before you can comment on or make changes to this bug.