Bug 72686 - Parted doesn't support MAXTOR 6L080L4
Parted doesn't support MAXTOR 6L080L4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: parted (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-26 13:55 EDT by hjl
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-25 14:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch (483 bytes, patch)
2002-08-26 18:12 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2002-08-26 13:55:32 EDT
Parted doesn't work on 80GB MAXTOR 6L080L4 IDE.
I got

Using /dev/hda
Error: The partition table on /dev/hda is inconsistent.  There are many reasons
why this might be the case.  However, the most likely reason is that Linux
detected the BIOS geometry for /dev/hda incorrectly.  GNU Parted suspects the
real geometry should be 155114/16/63 (not 9732/255/63).  You should check with
your BIOS first, as this may not be correct.  You can inform Linux by adding the
parameter hda=155114,16,63 to the command line.  See the LILO or GRUB
documentation for more information.  If you think Parted's suggested geometry is
correct, you may select Ignore to continue (and fix Linux later).  Otherwise,
select Cancel (and fix Linux and/or the BIOS now).

The problem is parted is wrong and BIOS/kernel is right. As the
result, my partition table created by parted is very strange:

Command (m for help): p

Disk /dev/hda: 255 heads, 63 sectors, 9732 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1             1        16    122944+  83  Linux
Partition 1 does not end on cylinder boundary:
     phys=(243, 15, 63) should be (243, 254, 63)
/dev/hda2            16       462   3584448   83  Linux
Partition 2 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
/dev/hda3           462       527    524664   82  Linux swap
Partition 3 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
/dev/hda4           527      9733  73945368   83  Linux
Partition 4 does not end on cylinder boundary:
     phys=(1023, 15, 63) should be (1023, 254, 63)
Comment 1 hjl 2002-08-26 18:12:05 EDT
Created attachment 73226 [details]
A patch
Comment 2 hjl 2002-09-14 16:34:15 EDT
Kernel reports:

blk: queue c03e2aa4, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03e2aa4, I/O limit 4095Mb (mask 0xffffffff)
hda: 160086528 sectors (81964 MB) w/2048KiB Cache, CHS=9964/255/63, UDMA(100)
blk: queue c03e2e00, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03e2e00, I/O limit 4095Mb (mask 0xffffffff)
hdc: 156355584 sectors (80054 MB) w/1819KiB Cache, CHS=155114/16/63, UDMA(33)
ide-floppy driver 0.99.newide
Partition check:
 hda: hda1 hda2 hda3 hda4 < hda5 >
 hdc: [PTBL] [9732/255/63] hdc1

It looks like kernel used a different geometry and
parted doesn't like it. When I put the same IDE
drive on a 3ware ATA card, it also reports 9732/255/63.
It looks like parted has a bug, but my patch may not be
the right fix. I think maybe we should port the kernel PTBL
stuff to parted.

Note You need to log in before you can comment on or make changes to this bug.