Bug 726933 - Problem with last kernel 3.0.1-0.rc0.git9.1.fc17.x86_64 and nouveau
Problem with last kernel 3.0.1-0.rc0.git9.1.fc17.x86_64 and nouveau
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-31 01:35 EDT by dominique
Modified: 2011-08-01 14:47 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-01 14:47:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dominique 2011-07-31 01:35:29 EDT
With the latest kernel 3.0.0-1.fc16.x86_64 I have problem with nouveau driver.
With previous kernel all work fine, I have good resolution (1440x900 for my laptop ), the desktop effect with kde work.

With this kernel 3.0.0-1.fc16.x86_64 I have a 640x400 resolution, and desktop effect don't work.

In the Xorg.0.log I can see :

.......................................................
[    28.303] drmOpenDevice: node name is /dev/dri/card0
[    28.320] [drm] failed to load kernel module "nouveau"
[    28.320] (EE) [drm] failed to open device
[    28.320] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[    28.320] (WW) Falling back to old probe method for fbdev
[    28.320] (II) Loading sub module "fbdevhw"
[    28.320] (II) LoadModule: "fbdevhw"
[    28.321] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[    28.321] (II) Module fbdevhw: vendor="X.Org Foundation"
[    28.321] 	compiled for 1.10.99.1, module version = 0.0.2
[    28.322] 	ABI class: X.Org Video Driver, version 10.0
[    28.322] (II) Loading sub module "vbe"
[    28.322] (II) LoadModule: "vbe"
[    28.322] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    28.331] (II) Module vbe: vendor="X.Org Foundation"
[    28.331] 	compiled for 1.10.99.1, module version = 1.1.0
[    28.331] 	ABI class: X.Org Video Driver, version 10.0
[    28.331] (II) Loading sub module "int10"
[    28.331] (II) LoadModule: "int10"
[    28.333] (II) Loading /usr/lib64/xorg/modules/libint10.so
[    28.346] (II) Module int10: vendor="X.Org Foundation"
[    28.347] 	compiled for 1.10.99.1, module version = 1.0.0
[    28.347] 	ABI class: X.Org Video Driver, version 10.0
[    28.347] (II) VESA(0): initializing int10
[    28.348] (II) VESA(0): Primary V_BIOS segment is: 0xc000
[    28.404] (II) VESA(0): VESA BIOS detected
[    28.404] (II) VESA(0): VESA VBE Version 3.0
[    28.404] (II) VESA(0): VESA VBE Total Mem: 14336 kB
[    28.404] (II) VESA(0): VESA VBE OEM: NVIDIA
[    28.404] (II) VESA(0): VESA VBE OEM Software Rev: 96.132
[    28.404] (II) VESA(0): VESA VBE OEM Vendor: NVIDIA Corporation
[    28.404] (II) VESA(0): VESA VBE OEM Product: G84 Board - p409h03 
[    28.404] (II) VESA(0): VESA VBE OEM Product Rev: Chip Rev   
[    28.503] (II) VESA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    28.504] (==) VESA(0): Depth 24, (--) framebuffer bpp 32
[    28.504] (==) VESA(0): RGB weight 888
[    28.504] (==) VESA(0): Default visual is TrueColor
[    28.504] (==) VESA(0): Using gamma correction (1.0, 1.0, 1.0)
[    28.504] (II) Loading sub module "ddc"
[    28.504] (II) LoadModule: "ddc"
[    28.504] (II) Module "ddc" already built-in
[    28.571] (II) VESA(0): VESA VBE DDC supported
[    28.571] (II) VESA(0): VESA VBE DDC Level none
[    28.571] (II) VESA(0): VESA VBE DDC transfer in appr. 0 sec.
[    28.845] (II) VESA(0): VESA VBE DDC read failed
[    28.846] (II) VESA(0): VESA VBE PanelID read failed
[    28.846] (II) VESA(0): Searching for matching VESA mode(s):
[    28.847] Mode: 100 (640x400)
..........................................................
Comment 1 Josh Boyer 2011-08-01 07:12:19 EDT
Does dmesg show anything about why the nouveau module did not load?
Comment 2 dominique 2011-08-01 11:46:36 EDT
There is no line with nouveau in dmesg when I boot with this kernel.

But there are fatal error with modprobe, I don't know if it's important :

Aug  1 17:28:59 localhost modprobe: FATAL: Could not load /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64/modules.dep: No such file or directory
Aug  1 17:28:59 localhost modprobe: FATAL: Could not load /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64/modules.dep: No such file or directory
Aug  1 17:28:59 localhost modprobe: FATAL: Could not load /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64/modules.dep: No such file or directory
Aug  1 17:28:59 localhost modprobe: FATAL: Could not load /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64/modules.dep: No such file or directory

but I see there is a file named modules.dep in /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64
Comment 3 Josh Boyer 2011-08-01 13:19:38 EDT
(In reply to comment #2)
> There is no line with nouveau in dmesg when I boot with this kernel.
> 
> But there are fatal error with modprobe, I don't know if it's important :
> 
> Aug  1 17:28:59 localhost modprobe: FATAL: Could not load
> /lib/modules/3.0.1-0.rc0.git9.1.fc17.x86_64/modules.dep: No such file or
> directory

Er... that kernel is not the one specified in the bug summary.  Which kernel are you having issues with?

Also, kernel-3.0.1-0.rc0.git9.1.fc17 is known to be broken because of some missing adjustments to how we package things.  Please upgrade to the latest f17 build (rc0.git15.1.fc17) if that is the kernel you are having issues with.
Comment 4 dominique 2011-08-01 13:33:21 EDT
Sorry, i made a mistake in summary, this bug is for 3.0.1-0.rc0.git9.1.fc17.x86_64.

I edit the summary ...

But I don't take attention I have installed an F17 kernel.

I want test F16, and I don't know why I have F17 kernel...
Comment 5 dominique 2011-08-01 14:00:19 EDT
Good new, update to kernel 3.1.0-0.rc0.git12.1.fc17.x86_64 solve problem...

Can you mark this bug as solved ?
Comment 6 Josh Boyer 2011-08-01 14:47:43 EDT
Thanks!

You probably have a f17 kernel installed because Fedora switched over to Branched, which means rawhide is now F17.

Note You need to log in before you can comment on or make changes to this bug.