Bug 727020 - ibus compose file needs a symbol tag for gnome-shell
ibus compose file needs a symbol tag for gnome-shell
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-skk (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-01 00:02 EDT by fujiwara
Modified: 2011-08-22 11:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: ibus-skk-1.3.7-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-03 23:31:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description fujiwara 2011-08-01 00:02:11 EDT
The latest ibus-gnome3 + gnome-shell can show a special symbol char on ibus
status icon by ibus engine.
The symbol can be defined in engine's /usr/share/ibus/component/*.xml .

Now ibus-anthy-1.2.6-3 has a symbol char and the similar fix is needed for
major ibus engines.

% grep symbol /usr/share/ibus/component/anthy.xml
   <symbol>&#x3042;</symbol>

The following patch is the example:
http://pkgs.fedoraproject.org/gitweb/?p=ibus-anthy.git;a=blob_plain;f=ibus-anthy-xx-icon-symbol.patch
http://pkgs.fedoraproject.org/gitweb/?p=ibus-hangul.git;a=blob_plain;f=ibus-hangul-xx-icon-symbol.patch

(Note: probably you don't need hotkeys tag since your engine would need Control
+ Space only for the trigger)
Comment 1 Fedora Update System 2011-08-03 23:29:58 EDT
ibus-skk-1.3.7-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-skk-1.3.7-2.fc16
Comment 2 Fedora Update System 2011-08-03 23:30:05 EDT
ibus-skk-1.3.7-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-skk-1.3.7-2.fc15
Comment 3 Fedora Update System 2011-08-12 06:55:24 EDT
ibus-skk-1.3.7-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2011-08-12 14:21:20 EDT
ibus-skk-1.3.7-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2011-08-22 11:18:49 EDT
ibus-skk-1.3.7-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.