Bug 72742 - gedit bugs (when write a Chinese document )
Summary: gedit bugs (when write a Chinese document )
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gedit (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: MoveUpstream, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-27 07:51 UTC by cirware
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 02:04:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description cirware 2002-08-27 07:51:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
There are some problems to use another editor (vim, Kword etc.) to read the 
documents that edited by "gedit".
We think the Character coding of Chinese (Big5) that "gedit" use might not be 
compatible with other editors. 
The situation is:
We use "gedit" to write a Chinese document and the content is "d8-f?f8,h)&". 
If we use vim to read it, everything we edit with "gedit" will be wrong like "?
e??g?e2?#034;. Even we use the "more" instruction, the content still could 
not be shown correct.
And the same situation happened when we edit an exited Chinese documents 
with "gedit". Every words will be unreadable.
 
It is very inconvenience to edit a Chinese document. Because "geidt" is the 
only choice to read the Chinese document edited by "gedit".  

 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Execute gedit editor to write a Chinese document 
2.If we use vim to read it, everything we edit with "gedit" will be wrong. 
Even we use the "more" instruction, the content still could not be shown 
correct.
3.
	

Additional info:

Comment 1 Havoc Pennington 2002-08-27 21:18:37 UTC
gedit is probably saving files in UTF-8. try running the files through
"iconf --from-code UTF-8 filename.txt" and if that fixes it this is the problem.

Comment 2 Havoc Pennington 2002-12-20 02:04:44 UTC
http://bugzilla.gnome.org/show_bug.cgi?id=85992 tracks this issue.


Note You need to log in before you can comment on or make changes to this bug.