Bug 72751 - rxvt does not write utmp
rxvt does not write utmp
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rxvt (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 07:35 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-10 10:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-27 07:35:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
rxvt does not write a utmp extry. rxvt has no suid bit, but then again,
nor does xterm which *does* write a utmp entry.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start rxvt
2.do a "w" command
3.observe
	

Actual Results:  i did not see an entry for the rxvt window in utmp.

Expected Results:  i should be seeing an entry for the rxvt window in utmp.

Additional info:

i have the latest patches and updates installed (27/08/2002)
Comment 1 Harald Hoyer 2002-11-11 08:33:37 EST
and 
$ rxvt -ls
to make a login shell???
Comment 2 Need Real Name 2002-11-14 07:28:31 EST
that doesn't work either, but since you asked me this, can i assume
it *does* work on your testmachines?
rxvt has the same problem in redhat 8.
Comment 3 Harald Hoyer 2002-11-14 08:08:18 EST
there is no rxvt in 8...
but you are right... rxvt should use utempter
so rxvt +ut -ls should work...
Comment 4 Harald Hoyer 2003-03-10 10:07:25 EST
there should be an erratum soon, which will fix the issue... watch out for
#84587 to get closed.

Note You need to log in before you can comment on or make changes to this bug.