Bug 727519 - virt-manager is missing several icons
Summary: virt-manager is missing several icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 11:16 UTC by Michal Nowak
Modified: 2013-03-08 02:12 UTC (History)
8 users (show)

Fixed In Version: virt-manager-0.9.0-5
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:14:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description Michal Nowak 2011-08-02 11:16:30 UTC
Description of problem:

virt-manager 0.9-4.el6 is missing several icons. E.g. icon in .desktop file because "Virtual Machine Manager" item in Menu does not hold any icon, and icon in About box is some sort of placeholder icon.

I also saw several other missing in Detail frame but can't say for sure since I can't open any VM due to bug 727414.

Comment 2 Cole Robinson 2011-08-02 17:54:02 UTC
We weren't updating the icon cache on rpm install. Easy way to test

reproduce:
yum remove virt-manager\*
# Make sure icon cache is refreshed by a conforming package
yum reinstall eog
yum install virt-manager
# Application->System Tools->virt-manager has no icon!

With the fixed package
yum remove virt-manager\*
# Make sure icon cache is refreshed by a conforming package
yum reinstall eog
yum install virt-manager
# Now we see the icons immediately

Comment 3 Cole Robinson 2011-08-02 17:54:25 UTC
Fixed in virt-manager-0.9.0-5

Comment 5 Huming Jiang 2011-08-12 02:56:19 UTC
According to comment 2:

Reproduce it with virt-manager-0.9.0-4.el6.x86_64.rpm

Verified with virt-manager-0.9.0-5.el6.x86_64.rpm

Steps:
yum remove virt-manager
# Make sure icon cache is refreshed by a conforming package
yum reinstall eog
rpm -ivh  virt-manager-0.9.0-5.el6.x86_64.rpm
# Now we see the icons immediately

So, move the status to Verified.

Comment 6 Cole Robinson 2011-11-07 16:41:19 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 7 errata-xmlrpc 2011-12-06 16:14:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.