Bug 727520 - Can't install or remove ibus-table-xingma
Summary: Can't install or remove ibus-table-xingma
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-table-xingma
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ding-Yi Chen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 11:20 UTC by Mike Ma
Modified: 2011-09-06 05:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 05:49:02 UTC


Attachments (Terms of Use)

Description Mike Ma 2011-08-02 11:20:00 UTC
Description of problem:
Can't install or remove ibus-table-xingma.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. sudo yum install ibus-table-xingma
2. sudo yum remove ibus-table-xingma #not installed
3. sudo yum install ibus-table-xingma #installed
  
Actual results:
I can add ZhengMa to my ibus.

Expected results:
Can't find it and can't reinstall, remove or install.

Additional info:

Comment 1 Mike Ma 2011-08-02 11:25:37 UTC
sorry I'm wrong.

Here are the real informations,
first I install it. didn't find anything. try to reinstall it.
1. sudo yum install ibus-table-xingma #didn't return anything
2. sudo yum remove ibus-table-xingma #not installed
3. sudo yum reinstall ibus-table-xingma #not installed.

Hope can fix it soon.

Comment 2 Ding-Yi Chen 2011-09-06 05:49:02 UTC
Hi Mike,

ibus-table-xingma is obsoleted by ibus-table-chinese, so it is no longer in repository.

In terms of ZhengMa, ibus-table-chinese does not include ZhengMa, because ZhengMa is not freely distributable, and ZhongYi (who possesses the copyright of ZhengMa) has filed lawsuit against Microsoft for not paying licence fee for Windows later than Windows 95.

If you do need ZhengMa, you can manually install ibus-table-xingma by:
1) Download ibus-table-xingma from http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=57191
2) Install it with sudo rpm -ivh ibus-table-xingma-1.2.0.20100305-3.fc15.noarch.rpm
3) Set version lock so yum update won't obsolete it, see Q4 in http://yum.baseurl.org/wiki/Faq
have detail explanation.

Regards,


Note You need to log in before you can comment on or make changes to this bug.