Bug 727532 - libvirt-cim service broken on boot
Summary: libvirt-cim service broken on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 11:54 UTC by Mike Burns
Modified: 2011-12-06 19:25 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-2.0.2-0.3.gitcf213a7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:25:45 UTC


Attachments (Terms of Use)
Patch (2.30 KB, patch)
2011-08-25 17:08 UTC, Mike Burns
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Mike Burns 2011-08-02 11:54:33 UTC
Description of problem:

cim server fails with the following error.

tog-pegasus: Generating cimserver SSL certificates.../usr/share/Pegasus/scripts/genOpenPegasusSSLCerts: line 50: /var/lib/Pegasus/log/install.log: Read-only file system
chmod: cannot access `/etc/Pegasus/*.pem': No such file or directory
cp: cannot stat `/etc/Pegasus/cert.pem': No such file or directory
cp: cannot stat `/etc/Pegasus/key.pem': No such file or directory
chmod: cannot access `/etc/Pegasus/file.pem': No such file or directory
chmod: cannot access `/etc/Pegasus/server.pem': No such file or directory
cp: cannot stat `/etc/Pegasus/server.pem': No such file or directory
chmod: cannot access `/etc/Pegasus/client.pem': No such file or directory
[FAILED]^M



Version-Release number of selected component (if applicable):
6.2-0.9

How reproducible:
Always

Steps to Reproduce:
1.boot ovirt-node
2.
3.
  
Actual results:
See description

Expected results:
starts and uses libvirt r/o socket

Additional info:
Need to ensure that it's using the read-only socket

Comment 2 Mike Burns 2011-08-25 17:00:59 UTC
Due to issues and time constraints, we're pulling libvirt-cim from rhevh.  We'll work upstream to get a libvirt-cim plugin that has all the correct configuration.

This bug will be used to pull libvirt-cim packages from the node, remove firewall configuration and all other cim config.

Comment 3 Mike Burns 2011-08-25 17:08:00 UTC
Created attachment 519934 [details]
Patch

Testing:  

libvirt-cim packages should be removed
libvirt-cim firewall ports should be closed
no mentions of libvirt-cim should appear anywhere

Comment 5 Ying Cui 2011-09-08 08:51:43 UTC
Verified this bug on RHEV-H 6.2-0.15 build.

Check the packages, there is no libvirt-cim and tog-pegasus packages installed.
The original messages in description is not here now. 
For firewall, 5989 port is closed.

Comment 6 Ying Cui 2011-09-08 08:52:25 UTC
Verified this bug on RHEV-H 6.2-0.15 build.

Check the packages, there is no libvirt-cim and tog-pegasus packages installed.
The original messages in description is not here now. 
For firewall, 5989 port is closed.

Comment 7 errata-xmlrpc 2011-12-06 19:25:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.