Bug 727554 - fake-build-provides provides lm_sensors-devel on x86_64
Summary: fake-build-provides provides lm_sensors-devel on x86_64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dennis Gregorovic
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 12:57 UTC by Jan Safranek
Modified: 2011-12-06 18:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 18:52:16 UTC


Attachments (Terms of Use)
root.log of failed build (54.05 KB, text/plain)
2011-08-02 12:58 UTC, Jan Safranek
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1743 normal SHIPPED_LIVE redhat-release enhancement update for Red Hat Enterprise Linux 6.2 2011-12-06 01:01:50 UTC

Description Jan Safranek 2011-08-02 12:57:26 UTC
Description of problem:
fake-build-provides provides lm_sensors-devel on x86_64. It should provide it only on architectures where we don't really have lm_sensors.

Version-Release number of selected component (if applicable):
fake-build-provides-1.0-46.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. mock -r rhel6-x86_64 net-snmp-5.5-31.el6.src.rpm

Actual results:
- build fails
- root log shows:
Executing command: ['/usr/bin/yum-builddep',  .....
Installing:
fake-build-provides         x86_64     1.0-46.el6

Expected results:
- build succeeds
- root log shows:
Executing command: ['/usr/bin/yum-builddep',  .....
Installing:
lm_sensors-devel      x86_64     ....

Comment 1 Jan Safranek 2011-08-02 12:58:42 UTC
Created attachment 516319 [details]
root.log of failed build

Comment 3 Daniel Mach 2011-08-02 15:14:13 UTC
fake-build-provides-1.0-47.el6 built and tagged into the RHEL 6.2 build root

Comment 5 Alexander Todorov 2011-08-22 13:39:02 UTC
In 0822.n.0 tree:
# rpm -qp --provides ./Server/s390x/os/Packages/fake-build-provides-1.0-47.el6.s390x.rpm | grep lm_sensors-devel
lm_sensors-devel  

Brew logs for net-snmp-5.5-34.el6 show that lm_sensors-devel package is installed into the buildroot on arches that have it.

Comment 6 errata-xmlrpc 2011-12-06 18:52:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1743.html


Note You need to log in before you can comment on or make changes to this bug.