Bug 727576 - Old mptsas driver
Summary: Old mptsas driver
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 13:56 UTC by Jim Knowler
Modified: 2011-08-02 14:19 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-02 14:19:49 UTC


Attachments (Terms of Use)

Description Jim Knowler 2011-08-02 13:56:42 UTC
Description of problem: This problem persists from closed bug 493093
https://bugzilla.redhat.com/show_bug.cgi?id=493093 

Version-Release number of selected component (if applicable):
modinfo mptsas
version:        3.04.19

How reproducible:


Steps to Reproduce:
1. modinfo mptsas
  
Actual results:
modinfo mptsas
filename:       /lib/modules/2.6.40-4.fc15.x86_64/kernel/drivers/message/fusion/mptsas.ko
version:        3.04.19
license:        GPL
description:    Fusion MPT SAS Host driver
author:         LSI Corporation
srcversion:     CE246E45B7D805FD7007375
alias:          pci:v00001000d00000062sv*sd*bc*sc*i*
alias:          pci:v00001000d00000058sv*sd*bc*sc*i*
alias:          pci:v00001000d00000056sv*sd*bc*sc*i*
alias:          pci:v00001000d00000054sv*sd*bc*sc*i*
alias:          pci:v00001000d00000050sv*sd*bc*sc*i*
depends:        mptscsih,mptbase,scsi_transport_sas
vermagic:       2.6.40-4.fc15.x86_64 SMP mod_unload
parm:           mpt_pt_clear: Clear persistency table: enable=1  (default=MPTSCSIH_PT_CLEAR=0) (int)
parm:           max_lun: max lun, default=16895  (int


Expected results:
Latest mptsas driver version

Additional info:
Dell's OMSA also reports the error
The current driver version 3.04.19 (mptlinux) is older than the required driver version 3.12.29.00 (mptlinux) for a controller of model 0x1F0F:  Controller 0 (SAS 6/iR Integrated)

Comment 1 Josh Boyer 2011-08-02 14:19:49 UTC
You should email LSI and ask them if and when they plan to update the upstream driver.  Fedora is not going to backport an out-of-tree version into F15 (or F16).


Note You need to log in before you can comment on or make changes to this bug.