Bug 727589 - KVM :Blue screen during installation with virtio driver- storport.sys.
Summary: KVM :Blue screen during installation with virtio driver- storport.sys.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.1
Hardware: x86_64
OS: Windows
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 14:37 UTC by Tomer
Modified: 2013-01-10 00:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 07:19:36 UTC


Attachments (Terms of Use)
Blue screen print screen (274.42 KB, image/png)
2011-08-02 14:37 UTC, Tomer
no flags Details

Description Tomer 2011-08-02 14:37:41 UTC
Created attachment 516332 [details]
Blue screen print screen

Description of problem:


Blue screen when trying to install windows2008R2x64 with virtio disk.
installing Windows2008R2 with floppy disk that contain viostor driver for virtio
disk. 
Blue screen happen during the installation process.

virtio drivers takes from: virtio-win-1.2.0-1.el6.noarch.rpm.

technical information indicate a problem in storport.sys

tested with ic135

Comment 3 Mike Cao 2011-08-03 03:02:38 UTC
I can not reproduce this issue with virtio-win-1.3.1-1.el6

steps:
1download virtio-win-1.3.1-1.el6.noarch.rpm and install it 
2.start guest w/ qemu-kvm 
/usr/libexec/qemu-kvm -m 4G -smp 4 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -boot menu=on -drive file=/home/test,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none,format=raw -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=76:0E:40:3F:2F:3F -boot dc -uuid dd5aee77-d635-41d4-92a0-4e59c3b5cb6c -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -name win2k8-storage -vnc :10 -drive file=/home/en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,id=drive-ide0-0-2,werror=stop,rerror=stop,cache=none,format=raw,media=cdrom,readonly=on -device ide-drive,drive=drive-ide0-0-2,id=ide0-0-2,bus=ide.0,unit=1 -device virtio-serial-pci,max_ports=16,indirect_desc=on -chardev socket,path=/tmp/virtio3,server,nowait,id=virtio3 -device virtserialport,chardev=virtio3,name=com.redhat.virtio.3 -fda /usr/share/virtio-win/virtio-win-1.3.1.vfd
3.in the installation steps ,load virtio storage driver

Results:
After step 3 ,installation completed.

Hi,Tomer

Could you try w/ newest virtio-win driver virtio-win-1.3.1-1.el6.noarch.rpm ?

Thanks,
Mike

Comment 4 Tomer 2011-08-03 10:17:30 UTC
Is still reproduced on my setup with the latest version virtio-win-1.3.1-1.el6.noarch.rpm.

Tested with Windows7x64.

Comment 5 Dor Laor 2011-08-11 21:00:39 UTC
What's the qemu-kvm and kernel version that you're using?
RHEV uses 6.1.z kernel too (although I don't think the issue is there)

Comment 6 Tomer 2011-08-14 09:10:58 UTC
qemu-kvm-tools-0.12.1.2-2.172.el6.x86_64
qemu-kvm-0.12.1.2-2.172.el6.x86_64

Linux black-vdsb.qa.lab.tlv.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

Comment 7 Mike Cao 2011-08-16 11:36:00 UTC
I still can not reproduce it .
following is my environments:

virtio-win-1.3.3-0.el6
kernel-2.6.32-188.el6.x86_64
qemu-kvm-0.12.1.2-2.183.el6.x86_64

RHEVM :IC116

steps:
install win08R2 guest with virtio-win-1.3.3.vfd with rhevm user portal


Actual Results:
installation successfully.

Comment 8 Vadim Rozenfeld 2011-08-16 13:07:04 UTC
(In reply to comment #6)
> qemu-kvm-tools-0.12.1.2-2.172.el6.x86_64
> qemu-kvm-0.12.1.2-2.172.el6.x86_64
> 
> Linux black-vdsb.qa.lab.tlv.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue
> May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

May I see the qemu command line, please.

Comment 9 Tomer 2011-08-22 12:52:15 UTC
It's not reproduce with the latest version ic137
installation finished with no problems.

tested  with win2k8R2 and win7x64 with virtio disk.
qemu-kvm-0.12.1.2-2.179.el6.x86_64
qemu-kvm-tools-0.12.1.2-2.179.el6.x86_64

Comment 11 Tomer 2011-08-25 07:09:45 UTC
Works with version ic137


Note You need to log in before you can comment on or make changes to this bug.