Bug 727641 - KMS fails horribly on AST 1100/2050/2100 graphics adapter in Dell C6145 with C410x attached and populated with two nVidia M2070's
Summary: KMS fails horribly on AST 1100/2050/2100 graphics adapter in Dell C6145 with ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-nouveau
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ben Skeggs
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 17:35 UTC by Mark Nipper
Modified: 2013-08-09 19:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-09 19:54:17 UTC


Attachments (Terms of Use)
requested lspci output (2.24 KB, application/gzip)
2012-03-12 15:45 UTC, Mark Nipper
no flags Details

Description Mark Nipper 2011-08-02 17:35:47 UTC
Description of problem:
When accepting the default installation parameters on a Dell C6145 with RHEL 6.1, the kernel hangs while booting into the installer due to what I believe is a failure in KMS with this particular graphics adapter.  The adapter shows:
---
AST 1100/2050/2100 VGA True Color Graphics and Video Accelerator
VBIOS Version 0.90.7a

during boot and lspci shows:
---
01:04.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 10)
---
01:04.0 0300: 1a03:2000 (rev 10)
---

Version-Release number of selected component (if applicable):
Whatever is on the ISO for 6.1.

How reproducible:
Every time.

Steps to Reproduce:
1. Boot installer without setting basic video driver (disabling KMS).
  
Actual results:
Hung installer.

Expected results:
Working installer.

Additional info:

Comment 2 Shyam Iyer 2011-08-11 16:05:20 UTC
Mark,

I realize you have had a few BIOS/hardware issues with this platform. Just making sure if the BIOS upgrades have helped you to resolve this issue.

I guess I am having a hard time trying to reproduce this issue.

Thanks,
Shyam

Comment 3 Mark Nipper 2011-08-12 19:07:37 UTC
Well, there's a good reason for that.  You probably didn't have a system with a C410x attached.  Our C410x has two nVidia M2070's in slots 0 and 15 (if I recall correctly).  Having this attached to the system was causing the hang.  So it seems that potentially one of the KMS drivers was doing something "bad" and causing the system to hang.

I was able to workaround the issue by either installing the base operating system without the C410x attached initially or just using the basic video driver.  I'm not sure how much it is worth even trying to figure this out other than it shouldn't cause the kernel to freeze in the first place.  But it is an odd hardware configuration to some extent.

Comment 4 Shyam Iyer 2011-08-12 19:34:21 UTC
(In reply to comment #3)
> Well, there's a good reason for that.  You probably didn't have a system with a
> C410x attached.  Our C410x has two nVidia M2070's in slots 0 and 15 (if I
> recall correctly).  Having this attached to the system was causing the hang. 
> So it seems that potentially one of the KMS drivers was doing something "bad"
> and causing the system to hang.
> 
> I was able to workaround the issue by either installing the base operating
> system without the C410x attached initially or just using the basic video
> driver.  I'm not sure how much it is worth even trying to figure this out other
> than it shouldn't cause the kernel to freeze in the first place.  But it is an
> odd hardware configuration to some extent.

I guess the only option is to use the basic video driver(vesa) to install. The nouveau driver driver does not support this card. 
You might talk to Dell support and they could point you to the nvidia binary drivers for this card after install.

Also, here is a relevant link about RH support on this card.
https://access.redhat.com/kb/docs/DOC-19565.pdf

Comment 5 RHEL Product and Program Management 2011-10-07 15:43:21 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Adam Jackson 2012-03-12 14:40:32 UTC
Can we get a full 'lspci -vnn' listing from this machine?

The ASPEED chips do not have kernel modesetting support in RHEL6.  So to the extent that 'nomodeset' solves your problems it's because it's preventing the nouveau driver from binding to the GPGPU board.  There's no reason why the nouveau driver should have that kind of problem, as far as I know, so ideally we'd fix nouveau so this just isn't an issue.

Reassigning to nouveau.

Comment 7 Mark Nipper 2012-03-12 15:45:15 UTC
Created attachment 569440 [details]
requested lspci output

Attaching requested lspci output.

Comment 8 Ben Skeggs 2012-07-11 07:41:27 UTC
Any update on this with a later RHEL release?


Note You need to log in before you can comment on or make changes to this bug.