Bug 727677 - autofs-5.0.1-0.rc2.156 now displays hostnames instead of IP addresses under /proc/mounts
Summary: autofs-5.0.1-0.rc2.156 now displays hostnames instead of IP addresses under /...
Keywords:
Status: CLOSED DUPLICATE of bug 725536
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs
Version: 5.7
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 20:28 UTC by Ricky Nelson
Modified: 2011-08-03 15:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-03 02:04:48 UTC


Attachments (Terms of Use)

Description Ricky Nelson 2011-08-02 20:28:48 UTC
Description of problem:
/proc/mounts and 'df' show NFS mount points with their respective IP address instead of the hostname after updating autofs under RHEL 5. The issue is not seen under RHEL 4 or RHEL 6 after updating their respective autofs packages.

Version-Release number of selected component (if applicable):
Pre upgrade:  autofs-5.0.1-0.rc2.143.el5_5.6.x86_64
Post upgrade: autofs-5.0.1-0.rc2.156.el5.x86_64

How reproducible:
Setup automount with NFS mount points. Cat out /proc/mounts or look at the output from 'df' to see that under version 143 of autofs the hostname is shown. Under version 156 the IP address is shown.

Additional info:
There is no change in behavior within the RHEL 6 updated autofs packages. I may be a bit off, but looking at the changelog under autofs-5.0.1-0.rc2.156.el5 I found the following:

* Mon Mar 28 2011 Ian Kent <ikent@redhat.com> - 5.0.1-0.rc2.151.el5
- bz629357 - [RFE] Automounter debug mode should include IP addresses
  - include ip address in debug logging.
  - mount using address for rr.

But this was replicated under RHEL 6 with BZ 629359, so I'm starting to think that neither of the above patches were the cause:

RHEL 5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=629357
RHEL 6 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=629359

By downgrading the autofs package from the 156 version to the 143 version the original behavior was seen again. Since we don't see this under RHEL 6, perhaps this was an unintentional error?

Comment 1 Ian Kent 2011-08-03 02:04:48 UTC
(In reply to comment #0)
> Description of problem:
> /proc/mounts and 'df' show NFS mount points with their respective IP address
> instead of the hostname after updating autofs under RHEL 5. The issue is not
> seen under RHEL 4 or RHEL 6 after updating their respective autofs packages.

Yes, that's right.

snip ...

> Additional info:
> There is no change in behavior within the RHEL 6 updated autofs packages. I may
> be a bit off, but looking at the changelog under autofs-5.0.1-0.rc2.156.el5 I
> found the following:
> 
> * Mon Mar 28 2011 Ian Kent <ikent@redhat.com> - 5.0.1-0.rc2.151.el5
> - bz629357 - [RFE] Automounter debug mode should include IP addresses
>   - include ip address in debug logging.
>   - mount using address for rr.
> 
> But this was replicated under RHEL 6 with BZ 629359, so I'm starting to think
> that neither of the above patches were the cause:
> 
> RHEL 5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=629357
> RHEL 6 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=629359
> 
> By downgrading the autofs package from the 156 version to the 143 version the
> original behavior was seen again. Since we don't see this under RHEL 6, perhaps
> this was an unintentional error?

Sorry you have had to spend time reporting this.

It was a mistake on my part due to an incorrect check for the
presence of multiple dns name records.

Unfortunately our internal testing discovered it way too late
to include the fix in the release.

We have another customer for which this is something of a
problem and I will be building a test package and putting
it on people.redhat.com today.

*** This bug has been marked as a duplicate of bug 725536 ***


Note You need to log in before you can comment on or make changes to this bug.