Bug 72769 - Packaging misses mimePart.php PEAR file
Packaging misses mimePart.php PEAR file
Status: CLOSED DUPLICATE of bug 70243
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 13:30 EDT by George Barbarosie
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-27 13:48:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Barbarosie 2002-08-27 13:30:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
In /usr/share/pear/Mail/mime.php:

     23 require_once 'PEAR.php';
     24 require_once 'Mail/mimePart.php';

The file Mail/mimePart.php is missing in the packaging, and has been for a long
time. Not even php-4.1.2-7.3.4.i386.rpm does not include it (the latest errata
update at the time of writing)

Version-Release number of selected component (if applicable): 4.1.2-7.3.4


How reproducible:
Always

Steps to Reproduce:
1. rpm -ql php | grep mimePart


Actual Results:  no ouput

Expected Results:  /usr/share/pear/Mail/mimePart.php

Additional info:

Workaround: get PHP sources tarball, grab the file manually and place it in
/usr/share/pear/Mail/mimePart.php
Comment 1 George Barbarosie 2002-08-27 13:48:27 EDT
I've checked out bug #70243 and it seems it was closed prior to the release of
php-4.1.2-7.2.3 (build date: Wed 21 Aug 2002). Still both this bug and bug
#70243 are valid (this one sould be marked a duplicate if #70243 is reopened)
Comment 2 Phil Copeland 2002-08-27 14:47:15 EDT

*** This bug has been marked as a duplicate of 70243 ***

Note You need to log in before you can comment on or make changes to this bug.