Bug 727693 - We should ship the BRMS code examples with the product
Summary: We should ship the BRMS code examples with the product
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: Documentation, Examples
Version: BRMS 5.1.1.GA
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: future
Assignee: Prakash Aradhya
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 21:58 UTC by Jeff Slone
Modified: 2013-03-06 04:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-06 04:20:16 UTC
Type: ---


Attachments (Terms of Use)

Description Jeff Slone 2011-08-02 21:58:37 UTC
Description of problem:
Currently, you have to dig through the community pages to find the BRMS examples referred to in the documentation, and those appear to be using community code, not productized code. There's no URL listed in the instructions for how to download them from JBDS. If you use either jboss.com or redhat.com, the download fails. Instead, we should do what the JBoss EAP and ESB teams do and bundle the examples with the product, since there don't appear to be valid versions of them anywhere on the Web.  

Version-Release number of selected component (if applicable):
5.1GA

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 lcarlon 2011-08-03 00:17:12 UTC
Jeff said:

If you use either jboss.com or redhat.com, the download fails. Instead, we should do what the JBoss EAP and ESB teams do and bundle the examples with the product, since there don't appear to be valid versions of them anywhere on the Web.


Agreed. My understanding is the EAP examples are managed by the build system and maintained alongside the product.

Anne-Louise, would be the best person to manage this?

Lee

Comment 2 lcarlon 2011-08-03 00:24:01 UTC
Sorry that should read:

Anne-Louise, who would be the best person to manage this?

Comment 3 Jeff Slone 2011-08-14 13:28:09 UTC
I think I've seen another bug report recently on this same issue. However, I can't find it now. You may want to close this if you can find the other bug report on the fact that the examples don't ship with the product. I believe engineering was trying to fix this for the 5.2 release.

Comment 4 Lukáš Petrovický 2011-08-14 16:12:53 UTC
The examples are part of the BRMS 5.2 builds.

Comment 5 Anne-Louise Tangring 2011-09-16 13:45:02 UTC
If this does works, we need to set brms 5.2 flag to +, please let Anne-Louise know.

Comment 6 Lukáš Petrovický 2011-09-16 14:11:00 UTC
We do ship the examples with 5.2, so I'm marking this VERIFIED. Anne-Louise, please add jboss-brms-5.2.0+.

Comment 7 lcarlon 2013-03-06 04:20:16 UTC
Closing as this is old and verified.


Note You need to log in before you can comment on or make changes to this bug.