Bug 727705 - [abrt] glibc-2.14-4: _dl_map_object_from_fd: Process /lib64/ld-2.14.so was killed by signal 11 (SIGSEGV)
Summary: [abrt] glibc-2.14-4: _dl_map_object_from_fd: Process /lib64/ld-2.14.so was ki...
Keywords:
Status: CLOSED DUPLICATE of bug 606527
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8ff51e426e232b7283a5fa5bd93...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-02 23:11 UTC by dashesy
Modified: 2016-11-24 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-04 14:57:19 UTC


Attachments (Terms of Use)
File: backtrace (58.37 KB, text/plain)
2011-08-02 23:11 UTC, dashesy
no flags Details

Description dashesy 2011-08-02 23:11:18 UTC
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /lib64/ld-linux-x86-64.so.2 --verify rt/2.6.33/arch/x86/vdso/vdso.so
component:      glibc
crash_function: _dl_map_object_from_fd
dso_list:       /lib64/ld-2.14.so glibc-2.14-4.x86_64 (Fedora Project) 1310408658
executable:     /lib64/ld-2.14.so
kernel:         2.6.38.8-35.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        glibc-2.14-4
reason:         Process /lib64/ld-2.14.so was killed by signal 11 (SIGSEGV)
time:           Tue Aug  2 16:58:50 2011
uid:            500
username:       ehsan

backtrace:      Text file, 59769 bytes

comment:
:(by mistake) issued the command: 
:ldd rt/2.6.33/arch/x86/vdso/vdso.so
:while was compiling kernel.
:
:vdso.so is from linux-rt 2.6.33.7.2-rt30

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-ehsan
:XDG_SESSION_ID=1
:HOSTNAME=ehsan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-GoAoyD/gpg:0:1
:SHELL=/bin/bash
:TERM=xterm
:XDG_SESSION_COOKIE=0bac5617b5d53c6210156e730000000a-1312223674.484305-1978696523
:HISTSIZE=1000
:WINDOWID=54593468
:GNOME_KEYRING_CONTROL=/tmp/keyring-GoAoyD
:IMSETTINGS_MODULE=none
:USER=ehsan
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:
:SSH_AUTH_SOCK=/tmp/keyring-GoAoyD/ssh
:USERNAME=ehsan
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1264,unix/unix:/tmp/.ICE-unix/1264
:DESKTOP_SESSION=gnome
:MAIL=/var/spool/mail/ehsan
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/ehsan/bin
:QT_IM_MODULE=xim
:PWD=/home/ehsan
:XMODIFIERS=@im=none
:LANG=en_US.UTF-8
:GNOME_KEYRING_PID=1256
:GDM_LANG=
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=3
:HOME=/home/ehsan
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=ehsan
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-75IvZaBSyb,guid=349b9f20d9954e1cd3e4e8a300000029
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/ehsan
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-ehsan-LzJ4vv/database
:COLORTERM=gnome-terminal
:_=/lib64/ld-linux-x86-64.so.2

event_log:
:2011-08-02-17:06:21> Querying server settings
:2011-08-02-17:06:22  Preparing an archive to upload
:2011-08-02-17:06:22  Uploading 6948 bytes
:2011-08-02-17:06:22  Upload successful
:2011-08-02-17:06:23  Retrace job started
:2011-08-02-17:06:34  Initializing virtual root
:2011-08-02-17:06:45  Initializing virtual root
:2011-08-02-17:06:56  Initializing virtual root
:2011-08-02-17:07:06  Initializing virtual root
:2011-08-02-17:07:17  Initializing virtual root
:2011-08-02-17:07:28  Initializing virtual root
:2011-08-02-17:07:39  Initializing virtual root
:2011-08-02-17:07:50  Generating backtrace
:2011-08-02-17:08:01  Retrace job finished successfully

maps:
:30cd600000-30cd61f000 r-xp 00000000 08:02 133445                         /lib64/ld-2.14.so
:30cd81e000-30cd820000 rw-p 0001e000 08:02 133445                         /lib64/ld-2.14.so
:30cd820000-30cd821000 rw-p 00000000 00:00 0 
:7f337aa9a000-7f337aa9b000 r-xp 00000000 08:02 3812340                    /home/ehsan/rt/2.6.33/arch/x86/vdso/vdso.so
:7ffff734d000-7ffff736e000 rw-p 00000000 00:00 0                          [stack]
:7ffff73ff000-7ffff7400000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

var_log_messages:
:Aug  2 16:58:50 ehsan kernel: [102232.792111] ld-linux-x86-64[21351]: segfault at 7f337aa9a590 ip 00000030cd6067e2 sp 00007ffff736b6c0 error 7 in ld-2.14.so[30cd600000+1f000]
:Aug  2 16:58:50 ehsan abrt[21352]: saved core dump of pid 21351 (/lib64/ld-2.14.so) to /var/spool/abrt/ccpp-2011-08-02-16:58:50-21351.new/coredump (167936 bytes)

Comment 1 dashesy 2011-08-02 23:11:22 UTC
Created attachment 516404 [details]
File: backtrace

Comment 2 Andreas Schwab 2011-08-03 08:49:05 UTC
There is no test case.

Comment 3 dashesy 2011-08-03 14:33:22 UTC
Here is a test case:

ldd /lib/modules/2.6.38.8-35.fc15.x86_64/vdso/vdso.so

It is 100% reproducible

Comment 4 Andreas Schwab 2011-08-04 14:57:19 UTC
That's not a valid ELF object.

Comment 5 Jakub Jelinek 2011-08-04 15:15:37 UTC
In particular, what isn't valid is that .dynamic section isn't in a writable segment.  It is fine when the kernel loads it and relocates it such that it has bias 0, but if it has non-zero bias, it can't be used by the dynamic linker.

Comment 6 Andreas Schwab 2011-08-04 15:16:48 UTC

*** This bug has been marked as a duplicate of bug 606527 ***


Note You need to log in before you can comment on or make changes to this bug.