This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 727721 - In document list view, title bar should show either project name only, or consistently show the previous edited document.
In document list view, title bar should show either project name only, or con...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity low
: Sprint-26
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-02 22:47 EDT by Ding-Yi Chen
Modified: 2011-10-28 03:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-28 03:25:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-08-02 22:47:40 EDT
Description of problem:
Currently in document list view, title bar shows:
1) ProjectName > No document selected if no document is clicked yet; or
2) ProjectName > DocumentName if we clicked DocumentName and come back from editing.

However, novice user might not be able to distinguish between document view and document list view; and misleading if the project status display is put in title bar as well.


Version-Release number of selected component (if applicable):
1.4-SNAPSHOT (20110801-1242).

How reproducible:
Always

Steps to Reproduce:
1. Log in to Zanata
2. Choose the project AboutFedora and version f13.
3. Click translate in any locale.
4. Document list view should be brought up at this stage, click a document,
say, "Article_Info" to enter document view.
5. Click on project name, AboutFedora, to go back to document list view.
6. Click on "Article_Info"
  
Actual results:
Title bar of document list view shows "About Fedora (f13) > Article_Info "

Expected results:
Title bar of document list view shows either 
"About Fedora (f13)"
or 
"About Fedora (f13)    Back to document [Article_Info]"
Comment 1 Sean Flanigan 2011-08-11 01:54:11 EDT
As long as the user can get back to the document (reliably, ie without having to reload the document), we don't need to make the other visual changes for 1.4.
Comment 2 Sean Flanigan 2011-08-11 02:09:11 EDT
It looks like the current behaviour is virtually the same as in 1.3, so I'm removing the blocker.  (I believe clicking the project name a second time used to close the doclist without reloading, probably in v1.2.)

When we get back to this, we should make sure that 'back to document' just closes the doclist, rather than trying to reload the document, since it's a waste of bandwidth.
Comment 3 Alex Eng 2011-08-12 01:25:34 EDT
Problem resolve. No cosmetic change. Increase performance when switching between Document List view and Editor view with same document selected.
Comment 4 Ding-Yi Chen 2011-09-26 19:40:12 EDT
VERIFIED with Zanata version 1.4-alpha-2-SNAPSHOT (20110926-1021)

Note You need to log in before you can comment on or make changes to this bug.