Bug 72774 - postgresql-dump command is missing
postgresql-dump command is missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-27 14:16 EDT by John Dalbec
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 08:34:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Dalbec 2002-08-27 14:16:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
/usr/share/doc/postgresql-7.2.1/README.rpm-dist describes upgrading the database after the RPM install using postgresql-dump.  But this command is not in the 
RPM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh postgres-*
2. postgresql-dump -t /var/lib/pgsql/backups/db.bak -p /var/lib/pgsql/backups/old -d

Actual Results:  bash: postgresql-dump: command not found


Expected Results:  postgresql-dump should create a backup of the old database

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-08-27 22:09:37 EDT
The release notes said to dump the database before upgrade. The script was
broken, and is therefore not included.
Comment 2 John Dalbec 2002-08-28 08:33:52 EDT
In that case README.rpm-dist should be modified to document this correctly or deleted.  If it is deleted, the initscript will need to be modified not to refer to it if the 
wrong database version is present.
Comment 3 Trond Eivind Glomsrxd 2002-08-28 11:42:28 EDT
It is mentioned in README.rpm-dist:

NOTE: This program is not included in the packages distributed with
Red Hat Linux. The releasenotes specifies a dump before a system
upgrade.
Comment 4 John Dalbec 2002-08-28 13:19:20 EDT
That's OK once you figure out that "this program" refers to the postgresql-dump program which is not mentioned by name until 5 paragraphs later.  
I'd prefer something like this:

NOTE: You cannot use the upgrade process described below on Red Hat Linux.  The postgresql-dump program used in the first step is not included in the packages 
distributed with Red Hat Linux because it is broken.  <Describe how it is broken and why you can't fix it.>  The releasenotes document specifies that you must dump 
the database before performing a system upgrade.



Note You need to log in before you can comment on or make changes to this bug.