Bug 727766 - Please hide unsupported SCSI and USB device types options in virt-manager
Summary: Please hide unsupported SCSI and USB device types options in virt-manager
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager   
(Show other bugs)
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords: Regression
: 913758 (view as bug list)
Depends On: 621933
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 07:34 UTC by min zhan
Modified: 2013-04-16 07:57 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: virt-manager offered SCSI and USB device creation in the UI, which are not supported at the qemu level. Consequence: selecting one of these models would prevent a guest from starting. Fix: hide unsupported models Result: no option to generate a broken guest configuration
Story Points: ---
Clone Of: 621933
Environment:
Last Closed: 2011-12-06 16:14:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Comment 4 Cole Robinson 2011-08-30 19:37:47 UTC
Fixed in virt-manager-0.9.0-6.el6

Comment 6 Huming Jiang 2011-09-02 06:22:14 UTC
Reproduced with virt-manager-0.9.0-5.el6.x86_64

Verified with the following components:
kernel-2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
libvirt-0.9.4-7.el6.x86_64
python-virtinst-0.600.0-2.el6.noarch
virt-manager-0.9.0-6.el6.x86_64.


Steps:
1. Using virt-manager create a new guest and assign standard 8GB virtio disk
2. Select to customize the guest before install
3. Add additional storage:
There is no storage device type about "scsi" and "usb".

Comment 7 Cole Robinson 2011-11-07 16:41:23 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 8 Cole Robinson 2011-11-07 17:39:14 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,11 @@
-No description necessary+Cause:
+virt-manager offered SCSI and USB device creation in the UI, which are not supported at the qemu level.
+
+Consequence:
+selecting one of these models would prevent a guest from starting.
+
+Fix:
+hide unsupported models
+
+Result:
+no option to generate a broken guest configuration

Comment 9 errata-xmlrpc 2011-12-06 16:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html

Comment 10 Martin Kletzander 2013-04-16 07:57:02 UTC
*** Bug 913758 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.