Bug 727789 - RFE: "Create Project" for non-administrator users
RFE: "Create Project" for non-administrator users
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
urgent Severity medium
: ---
: 1.6-alpha-1
Assigned To: Carlos Munoz
Joyce Chang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-03 05:02 EDT by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: Zanata version 1.6-SNAPSHOT (20120321-1619)& 1.5.1-SNAPSHOT (20120403-1100)
Doc Type: Bug Fix
Doc Text:
Cause Creating a new translation project required server administrator privileges. Consequence Users had to request a translation project through a ticketing system and wait for a server administrator to create the project on their behalf. Change The ability to create a project was granted to any user with a valid account on the server, and the user interface was modified to make this ability accessible. Result Users can now create a translation project by following these steps: 1. Log in 2. Click “Project” 3. Click “Create project” 4. Fill in “Project ID”,”Name”,”Description” 5. Click “Save” Note that the user who creates the project becomes the project's owner.
Story Points: 3
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2011-08-03 05:02:10 EDT
At the moment an administrator can "Create a project".

However, there is no provision for an authenticated user to request a project.

Can we add a link for authenticated, non-administrative users to "Request a project".

We would also need a server-configurable parameter for "administration queue email". 

When requesting a project, the user will fill in a form specifying details such as Project Name, requestor email contact, user names of maintainers (optional), etc.

On form submission, the form contents will be emailed to the configured administration queue email for administrator attention.
Comment 1 Sean Flanigan 2011-09-07 00:33:41 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Joshua Wulf 2011-11-22 18:22:28 EST
Maybe we're better off allowing anyone to create a project, and then
restricting it if it turns out to be a problem.

That would eliminate a bottleneck and a lot of administration overhead
and use friction.

Separately, but related: we could make it that the creator of a project
can delete it. It wouldn't be deleted, it would just become invisible.
Comment 3 David Mason 2011-11-22 19:07:57 EST
"administration queue email" could use "Contact Admin Address" in the current server configuration page. This is the list of email addresses that will be the recipient for anything sent through  Help -> Contact Admin  or through  Languages -> <Language> -> Contact Team Coordinators / Request To Join Team  if there is no coordinator for the language team.

Adding  Projects -> Request A Project  should be fairly straightforward.
Comment 4 Joshua Wulf 2012-02-16 20:05:17 EST
We really need the ability for users to add projects. It's a bottleneck, and it really ruins the flow of getting people in there.
Comment 5 Carlos Munoz 2012-03-12 01:21:13 EDT
Added a feature to allow any authenticated user to create a project. The project creator will automatically become the project's maintainer.

These changes also correct bug 730199.

See:
https://github.com/zanata/zanata/commit/e8afa8a65f47aceac35ce2ebd8cc97517badadf0
https://github.com/zanata/zanata/commit/ad01b3f915e4f776cd6604f20cce3a49bf3489ee
Comment 6 Joyce Chang 2012-03-19 23:34:58 EDT
I have logged in as a non-admin/an admin to test the new feature over several testing machines but errors always occurred after following actions.

step 1 log in
step 2 click “project”
step 3 click “create project”
step 4 fill in “Project ID”,”Name”,”Description”
step 5 click “save”

Expected Result:

Project “XXXX” successfully created

Actual Result:

HTTP Status 404 - /error.seam.seam
type Status report
message /error.seam.seam
description The requested resource (/error.seam.seam) is not available.
JBoss Web/2.1.12.GA-patch-01
Comment 8 Joyce Chang 2012-03-20 19:14:16 EDT
verified in Zanata version 1.6-SNAPSHOT (20120320-1641).
Comment 9 Carlos Munoz 2012-03-22 21:40:46 EDT
Joyce, can you please retest with 1.5.1-SNAPSHOT?
Comment 10 Joyce Chang 2012-03-26 05:29:34 EDT
Hi Carlos,

I tested 1.5 version by logging in as admin and non-admin both, following is what happened after testing


step1 login as a non-admin user/admin 
step2 click "Projects"
step3 Click "Create Projects"
Step4 Fill in Project Id, Project Name,Project Description and Project Content
step3 Click "Save"



Expected Results:

Project was successfully created 
non admin user/admin will automatically be maintainer after project creation
non admin user creating the project and admin will be able to edit project 

Actual results:

Project was successfully created 
return "Unexpected error. Please try again." after clicking "Edit project"
return "Unexpected error. Please try again." after clicking "project name" of the project just created
Comment 11 Joyce Chang 2012-03-26 05:35:32 EDT
one more is missing
Actual results:
non admin user/admin becomes project maintainer after project creation
Comment 12 Carlos Munoz 2012-03-30 03:07:29 EDT
Worked in all 1.5 test servers with exception of autotest. Redeployed to autotest and issue seems to have gone away. Please retry verification.
Comment 13 Joyce Chang 2012-04-03 19:42:59 EDT
verified in Zanata version 1.5.1-SNAPSHOT (20120403-1100)
Comment 14 Joshua Wulf 2012-04-17 01:31:34 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Creating a new translation project required server administrator privileges.

Consequence
Users had to request a translation project through a ticketing system and wait for a server administrator to create the project on their behalf.

Change
The ability to create a project was granted to any user with a valid account on the server, and the user interface was modified to make this ability accessible.

Result
Users can now create a translation project by following these steps:

1. Log in
2. Click “Project”
3. Click “Create project”
4. Fill in “Project ID”,”Name”,”Description”
5. Click “Save”

Note that the user who creates the project becomes the project's owner.

Note You need to log in before you can comment on or make changes to this bug.