Bug 727855 - [webadmin] Storage main tab adjustments
Summary: [webadmin] Storage main tab adjustments
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: m2
: 3.1
Assignee: Vojtech Szocs
QA Contact:
URL:
Whiteboard:
Depends On: 728774
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 12:37 UTC by Einav Cohen
Modified: 2012-08-09 07:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-09 07:58:00 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Einav Cohen 2011-08-03 12:37:42 UTC
Main grid:
- Make sure that Storage Type being translated
- filtering the correct sub-tabs according to storage type - not working well

General sub-tab:
	- Missing Over-Allocation Ratio
	- Need to show only relevant items according to storage type (e.g. "Local path on Host" should be shown only for local storage)

For Export domains: Rename "Virtual Machines Backup" sub-tab to "VM Import"
For Export domains: Rename "Template Backup" sub-tab to "Template Import"

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Vojtech Szocs 2011-08-05 15:52:51 UTC
> Make sure that Storage Type being translated
Should be OK, values in "Storage Type" column are properly translated from StorageType enum using uicompat's EnumTranslator. Translations for enums can be found in 'org/nogah/uicompat/Enums.properties' file (uicompat project). I tested this for data (master), export and iso domain.

> filtering the correct sub-tabs according to storage type - not working well
This is controlled by UiCommon, however for me it behaves the same as in WPFClient:
- selecting 'Export' DomainType = General, Data Center, VM Import, Template Import, Permissions
- selecting 'ISO' DomainType = General, Data Center, Images, Permissions
- selecting 'Data (master)' DomainType = General, Data Center, Virtual Machines, Templates, Permissions

Changes according to WPFClient:
Sub-tab label 'ISO Images' renamed to 'Images'
Sub-tab label 'Data Centers' renamed to 'Data Center'

> For Export domains: Rename "Virtual Machines Backup" sub-tab to "VM Import"
> For Export domains: Rename "Template Backup" sub-tab to "Template Import"
Since 'Virtual Machine Backups' and 'Template Backups' sub-tabs are only visible when Export domain is selected, their labels were simply renamed to 'VM Import' and 'Template Import'.

Comment 2 Vojtech Szocs 2011-08-05 16:03:27 UTC
Tasks still to do:
- revisit Storage General sub-tab (description above)
- verify that VmBackupModel ('VM Import' sub-tab) and TemplateBackupModel ('Template Import' sub-tab) are async

Comment 3 Einav Cohen 2011-08-07 11:24:40 UTC
Let's wait with the remaining issues until Bug 728774 (which is about turning the Storage-related models to async) is solved.

Comment 4 Vojtech Szocs 2011-08-16 11:25:22 UTC
Storage General sub-tab issues fixed with respect to FormBuilder approach (which should be the default way of implementing form-based content).

Comment 5 Vojtech Szocs 2011-08-30 11:52:50 UTC
Fixed an issue where sub-tabs, which should be initially hidden, were visible when selecting main-tab table item for the first time.

Comment 6 Itamar Heim 2012-08-09 07:58:00 UTC
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/


Note You need to log in before you can comment on or make changes to this bug.