Bug 72786 - X no longer works
Summary: X no longer works
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-session
Version: null
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-27 19:59 UTC by Carlos Chavez
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2002-09-02 21:42:20 UTC


Attachments (Terms of Use)
Xfree logs (6.82 KB, text/plain)
2002-08-27 20:00 UTC, Carlos Chavez
no flags Details
XFree log unpacked (30.29 KB, text/plain)
2002-08-29 16:36 UTC, Richard Torkar
no flags Details
Xfree log 2 unpacked (32.00 KB, text/plain)
2002-08-29 16:37 UTC, Richard Torkar
no flags Details

Description Carlos Chavez 2002-08-27 19:59:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When computer boots I only get a message that X is respawning too fast and 
will be disabled.  When I log in to a console and run startx the screen 
changes to graphical mode and opens an Xterm.  I get no borders on the Xterm 
window.  The mouse is functonal.  I can load any X program I want, but there 
seems to be no window manager available.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.just by starting my computer
2.
3.
	

Actual Results:  only a black screen loads and presents a white Xterm that 
occupies 1/4 of the screen at 1024x768

Expected Results:  my normal desktop was Gnome.

Additional info:

Comment 1 Carlos Chavez 2002-08-27 20:00:51 UTC
Created attachment 73364 [details]
Xfree logs

Comment 2 Richard Torkar 2002-08-29 16:36:29 UTC
Created attachment 73752 [details]
XFree log unpacked

Comment 3 Richard Torkar 2002-08-29 16:37:09 UTC
Created attachment 73753 [details]
Xfree log 2 unpacked

Comment 4 Carlos Chavez 2002-08-29 17:59:12 UTC
I now believe that it is not an X problem.  The real problem is that the Gnome
enviroment is not loading.  Once I hace the Xterm I can then run Metacity and
then the gnome-panel.

Comment 5 Mike A. Harris 2002-09-01 10:26:20 UTC
Reassigning to gnome-core

Comment 6 Havoc Pennington 2002-09-02 21:33:57 UTC
cursor, it loads for other people. What might be different about your system?

Do you have a fresh null, or null plus some updates?

What is in ~/.xsession-errors after the failed login?

Comment 7 Carlos Chavez 2002-09-02 21:42:12 UTC
I'm afraid that I had to reintall my system so I no longer have any log files. 
The problem has not reappeared.  My system worked for a week last time before
the problem presented itself.

I'm running a notebook with a PIII/933, SiS630 chipset, 256mb ram, 15gb HD.  The
only updates I got were the kernel core and source which came through UP2DATE.

Comment 8 Mike A. Harris 2002-09-03 22:54:31 UTC
Sounds to me like it could have been a case of "we fixed it in the
latest default configs, but the bug exists in the server itself
still, so if you use an old config, you get bit until you reconfigure"

perhaps...  closing as RAWHIDE since you've indicated the problem
went away.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.