Bug 727871 - Bad message parsing when reading from virto-serial socket
Summary: Bad message parsing when reading from virto-serial socket
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Dan Kenigsberg
QA Contact: Jakub Libosvar
URL:
Whiteboard:
Depends On: 727529
Blocks: 727647
TreeView+ depends on / blocked
 
Reported: 2011-08-03 13:40 UTC by Gal Hammer
Modified: 2011-12-06 07:36 UTC (History)
4 users (show)

Fixed In Version: vdsm-4.9-92
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:36:31 UTC


Attachments (Terms of Use)
An example script which send messages to vdsm (3.32 KB, application/octet-stream)
2011-08-04 07:28 UTC, Gal Hammer
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Gal Hammer 2011-08-03 13:40:43 UTC
Description of problem:

vdsm seems to read only one message at a time. This mean that if a lot of messages are been send in a small time period, vdsm handle only the first message. The next message is handled only after more messages are read.

How reproducible:

Use the attach script to send messages from the guest to vdsm. You'll see that the client ip is not updated.

Comment 2 Dan Kenigsberg 2011-08-03 19:37:09 UTC
http://gerrit.usersys.redhat.com/785

Comment 7 Jakub Libosvar 2011-08-24 14:14:46 UTC
Verified using vdsm-4.9-95

Comment 8 errata-xmlrpc 2011-12-06 07:36:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.