Bug 72790 - GUI Install crashes on FireGL 8800
GUI Install crashes on FireGL 8800
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 81225 (view as bug list)
Depends On:
Blocks: 79579 82776
  Show dependency treegraph
 
Reported: 2002-08-27 16:51 EDT by James Riggs
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-05 12:32:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (5.39 KB, text/plain)
2002-12-31 04:54 EST, Bastien Nocera
no flags Details
XFree86 log (20.06 KB, text/plain)
2002-12-31 04:55 EST, Bastien Nocera
no flags Details
log when trying to use the radeon driver (17.33 KB, text/plain)
2003-01-21 07:27 EST, Bastien Nocera
no flags Details
lspci -vvn (9.19 KB, text/plain)
2003-02-03 12:45 EST, Patrick C. F. Ernzer
no flags Details
glxinfo (1.84 KB, text/plain)
2003-02-03 13:15 EST, Patrick C. F. Ernzer
no flags Details
standard err when calling glxinfo (58 bytes, text/plain)
2003-02-03 13:16 EST, Patrick C. F. Ernzer
no flags Details
xdpyinfo (4.04 KB, text/plain)
2003-02-03 13:16 EST, Patrick C. F. Ernzer
no flags Details
XF86Config generated by redhat-config-xfree86-0.7.3-1 (3.25 KB, text/plain)
2003-02-03 13:17 EST, Patrick C. F. Ernzer
no flags Details
log of XFree86 (56.02 KB, text/plain)
2003-02-03 13:18 EST, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description James Riggs 2002-08-27 16:51:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020827

Description of problem:
GUI install is failing on an ATI FireGL 8800.  I am attempting to install using
the iso images on an NFS share.  Installed fine using the Matrox G450 card.

Here are the messages I get.

Running anaconda, the Red Hat Linux system installer - please wait...
Probing for video card:		ATI FireGL 8800
Probing for monitor type:	IBM P275
Probing for mouse type:		Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.

(mini-wm:97): GTK-WARNING **: cannot open display:  :1
Traceback (most recent call last):
   File "/usr/bin/anaconda", line 535, in ?
      from splashscreen import splashScreenShow
   File "/usr/lib/anaconda/splashscreen.py", line 20, in ?
      import gtk
   File "/usr/lib/python2.2/site-packages/gtk/__init__.py", line 19, in ?
      from _gtk import *
RuntimeError: could not open display
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/mnt/source2 done
	disabling /dev/loop1
	/proc/bus/usb done
	/proc done
	/dev/pts done
	/mnt/source done
you may safely reboot your system


Then I did a three finger salute and tried the install again and got the following:

Running anaconda, the Red Hat Linux system installer - please wait...
Probing for video card:		ATI FireGL 8800
Probing for monitor type:	IBM P275
Probing for mouse type:		Generic - 3 Button Mouse (PS/2)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5....X SERVER FAILEDAttempting to start VESA driver X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Attempt an install with an ATI FireGL 8800 in the system.
2.
3.
	

Actual Results:  Anaconda exits

Expected Results:  Install to continue.

Additional info:
Comment 1 Michael Fulbright 2002-08-28 13:00:46 EDT
Mike do you have hw to reproduce this?

I do not have access to it here.
Comment 2 Michael Fulbright 2002-09-02 11:04:27 EDT
Mike H - any progress?
Comment 3 Mike A. Harris 2002-09-03 12:42:33 EDT
Same PCI ID as Radeon 8500.  Should just work.  I've got a FireGL
entry in the hardware database for it, however, removing that from
the database won't prevent the card from being detected anyway since
it has the same PCI ID as Radeon 8500.   There's nothing we can
do about this for our final release at this point.  I will investigate
it for the future however.

Comment 4 Bastien Nocera 2002-12-31 04:53:17 EST
On my machine, the card is detected properly and I can go through the
installation process. Attached XFree86 log and lspci output below.
Comment 5 Bastien Nocera 2002-12-31 04:54:27 EST
Created attachment 88997 [details]
lspci output
Comment 6 Bastien Nocera 2002-12-31 04:55:52 EST
Created attachment 88998 [details]
XFree86 log
Comment 7 Mike A. Harris 2002-12-31 05:06:09 EST
Adding info from IRC:

<hadess> ok, it's P/N 102-85720-00

That is for the last two comments
Comment 8 Mike A. Harris 2002-12-31 05:10:09 EST
The PCI ID is different from other FireGL 8800's, which indicates ATI makes
boards with different PCI IDs all called FireGL 8800.  Grrrrrrrrrr.

Oh well, I should be able to fix this easily enough I think.
Comment 9 Mike A. Harris 2002-12-31 06:10:59 EST
Ok, I am going to download ATI's Catalyst and FGL drivers for Windows and
Linux and see if I can extract all known PCI IDs from them and add support
across the board.
Comment 10 Mike A. Harris 2003-01-02 07:19:40 EST
Good news.  I have implemented support for these FireGL chips, and it will
be in rawhide hopefully for the next beta.  There is some other missing
hardware I want to add in as well first, and clean some things up.  I'll
update the report as soon as I have official test rpms available though.

I'll also backport it to 4.2.1 later on too, so 8.0 is supported in erratum.
Comment 11 Mike A. Harris 2003-01-17 03:50:05 EST
Bug was marked private unnecessarily for some reason.  Marking public.
Comment 12 Mike A. Harris 2003-01-17 03:50:25 EST
*** Bug 81225 has been marked as a duplicate of this bug. ***
Comment 13 Bastien Nocera 2003-01-21 07:26:01 EST
Updated the machine to the new Phoebe beta. XFree86 -configure detects the card,
but uses the vesa driver. Trying to use the radeon driver fails.

Attached XFree log below when trying to use the radeon driver.
Comment 14 Bastien Nocera 2003-01-21 07:27:25 EST
Created attachment 89459 [details]
log when trying to use the radeon driver
Comment 15 Patrick C. F. Ernzer 2003-01-31 08:10:03 EST
FWIW: this happens with redhat-config-xfree86-0.7.2-2

Script started on Fri 31 Jan 2003 01:02:01 PM GMT
[root@lotte root]# rpm -qf `which redhat-config-xfree86`
redhat-config-xfree86-0.7.2-2
[root@lotte root]# redhat-config-xfree86
  File "/usr/share/redhat-config-xfree86/xconf.py", line 357
    current_card_driver = current_card.getCardData()["DRIVER"]
                      ^
SyntaxError: invalid syntax
[root@lotte root]# rpm -V redhat-config-xfree86
[root@lotte root]# 
Script done on Fri 31 Jan 2003 01:02:40 PM GMT

Is this to be expected?
Comment 16 Mike A. Harris 2003-01-31 09:22:15 EST
I haven't applied my patch to the rawhide builds yet because I was waiting
for upstream major changes to finish so I didn't have to redo everything
several times.  Now the majority of upstream Radeon driver changes seem
to be almost complete.  I'll be porting my patch to the current codebase
and putting it in rawhide soon.

pcfe: Upgrade r-c-x to the latest version in the internal development tree
and if it still fails, file a bug report against r-c-x.
Comment 17 Patrick C. F. Ernzer 2003-01-31 09:57:43 EST
to not leave the last question open-ended:

the syntax error does not happen with redhat-config-xfree86-0.7.2-3, it
recognizes the card as Radeon 9700. Dunno if Fire GL X1 = radeon 9700 but at
least X comes up.
Comment 18 Mike A. Harris 2003-02-01 01:02:01 EST
FireGL X1 is R300 based and is basically the high-end version of the
Radeon 9700 Pro.  I don't have this hardware, nor the details, but if
time permits I'll try to make it autodetect properly also.

Please attach lspci -vvn for the X1.
Comment 19 Mike A. Harris 2003-02-01 20:07:34 EST
I have now added my patches to an official build.  Support for 8 previously
unsupported Radeon R200 family chips including various Radeon 8500 chips,
FireGL 8700, FireGL 8800, and the new Radeon 9100 from Sapphire are now all
supported in both 2D, 3D, and Xv in XFree86-4.2.99.4-20030129.4 in rawhide.

In addition, over 30 new ATI Rage 128 chips that were previously unsupported
are now supported including previously missing Rage 128 Pro Ultra chips,
and other Rage 128 Pro chips as well.

I have not yet updated the hwdata package for all of these new chips, but
the FireGL ones are in there already IIRC.

Please test this out and let me know how it works for you.  I have tested it
on the FireGL 8800 that Jim sent me and it seems to work well.
Comment 20 Mike A. Harris 2003-02-01 20:09:48 EST
Oh, I forgot to mention... please change the bug state to RAWHIDE after
confirming the new driver works properly.  Open new bug reports if new
problems are encountered, or set this one to ASSIGNED if it doesn't work
for you.

Thanks for being patient guys while I waited for CVS to stabilize.  It saved
me a lot of work.
Comment 21 Patrick C. F. Ernzer 2003-02-03 12:45:11 EST
Created attachment 89805 [details]
lspci -vvn

as this is a Dell machine, you can look up it's specs via the service tag
398J521
Comment 22 Patrick C. F. Ernzer 2003-02-03 13:15:27 EST
2D seems to work fine (same as comment #17), 3D does not. tuxracer and chromium
are slow as hell. Output from glxinfo and xdpyinfo follows.

XFree86 4.2.99.4-20030129.4

kernel-smp-2.4.20-2.30.i686.rpm

from the internal Surrey mirror of rawhide
Comment 23 Patrick C. F. Ernzer 2003-02-03 13:15:55 EST
Created attachment 89808 [details]
glxinfo
Comment 24 Patrick C. F. Ernzer 2003-02-03 13:16:30 EST
Created attachment 89809 [details]
standard err when calling glxinfo
Comment 25 Patrick C. F. Ernzer 2003-02-03 13:16:55 EST
Created attachment 89810 [details]
xdpyinfo
Comment 26 Patrick C. F. Ernzer 2003-02-03 13:17:44 EST
Created attachment 89811 [details]
XF86Config generated by redhat-config-xfree86-0.7.3-1
Comment 27 Patrick C. F. Ernzer 2003-02-03 13:18:47 EST
Created attachment 89812 [details]
log of XFree86
Comment 28 Mike A. Harris 2003-02-03 22:35:30 EST
pcfe: 3D will be slow indeed, because that card is not 3D accelerated under
DRI.  The new Radeon 9500/9700 are 2D *only* in XFree86 CVS and will be
in 4.3.0 as well.  There will be no 3D support for Radeon 9500/9700 or
ATI newest FireGL products in open source drivers anytime soon.

Any chip that is R300 based will be 2D only in XFree86 4.3.0 and in
our next Red Hat Linux release.

If it works in 2D, then it's working right now properly to the extent
of what we support.

I will however update our hardware database to make sure this card is
cosmetically named properly in the config tools and anaconda et al.  I've
also databased your lspci info in my stash.  Thanks for the details.

Since such a card is super expensive - even if it is a freebie..  you
probably will want to try ATI's binary drivers from their website, which
provide full 3D support, etc. for the card.  Note however that just like
Nvidia's proprietary driver that we don't support it yada yada.  ;o)

Take care.
Comment 29 Patrick C. F. Ernzer 2003-02-04 12:47:06 EST
Mike,

O.K. will use the ATI binary drivers once all the testing is done, untill then
duty comes before playing ;-P

Is it possible for you to remove the 'Enable 3D support' button on cards where
we do not support 3D? Preferably replacing it with a text '3D not supportred on
this hardware'? That should cut down on the support calls we'll get on these cards.

PCFE
BTW: As far as I'm concerned the bug can be closed once the cosmetic changes
have been made (even if the request about disabling the 3D support button does
not go in)
Comment 30 Mike A. Harris 2003-02-04 18:19:59 EST
The redhat-config-xfree86 tool is not part of XFree86, and not something
I maintain.  Feel free to make a request for enhancement against the
tool though, and Brent can investigate.

Note that right now there is no easy way to determine wether or not 3D
is supported on a given video card.  Only the driver source code knows
for sure.  We grey out the 3D accel box (which really should be called
DRI because it is NOT just for 3D acceleration) if the whole driver
does not support 3D.  For a driver which supports 3D on some subset of
the hardware it supports, we have no way of telling what hardware is
supported programatically.  So this wont likely change for our next
release.
Comment 31 Patrick C. F. Ernzer 2003-02-05 05:15:36 EST
OK, as we have no way of telling I will not do an RFE then.
Comment 32 Bastien Nocera 2003-02-05 12:17:33 EST
Upgraded XFree86 makes my FireGL card work, minus 3D acceleration. Thanks for
the work Mike.
Comment 33 Mike A. Harris 2003-02-05 12:32:27 EST
3D acceleration should work as long as you are using rawhide kernel.
If it doesn't, please open a new bug report against rawhide for
FireGL 3D not working and attach new config file, log file, and
/var/log/messages to it.

Thanks hadess.

Closing as RAWHIDE as indication it works above.  I plan on backporting
this to 8.0 sometime in the future though also.
Comment 34 James Riggs 2003-02-06 15:59:29 EST
Finally installed XFree from Rawhide with Rawhide kernel.  FireGL8800 came up no
problem.  Started Chromium and it ran fine.

Thanks a lot for the work Mike

Note You need to log in before you can comment on or make changes to this bug.