Bug 727915 - multiple HDMI outputs not usable
Summary: multiple HDMI outputs not usable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 16:02 UTC by Tomasz Torcz
Modified: 2013-02-16 16:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-16 16:01:28 UTC


Attachments (Terms of Use)

Description Tomasz Torcz 2011-08-03 16:02:57 UTC
Description of problem:
I have Intel H67-based board with Display Port and HDMI outputs. aplay -l/-L list them as:

hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output

card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Those audio HDMI's are fix-routed:
- HDMI 0 means output through Display Port connector
- HDMI 1 outputs through HDMI connector

I have TV connected to HDMI connector. By default, when I switch PA default output to HDMI in GNOME Sound Preferences, I have _no sound_ in TV. This is because PA defaults to "HDMI0".

I can force output to HDMI 1 using "hdmi:0,1" string in application like mplayer.

The problem is that PA don't give a choice between HDMI0 and HDMI1, giving only "HDMI" (which apparently maps to HDMI0).

I workarounded problem by hardcoding following in profile in /usr/share/pulseaudio/alsa-mixer/profile-sets/default.conf:

[Mapping hdmi-tv-stereo]
device-strings = hdmi:0,1
channel-map = left,right
priority = 4
direction = output

Now I can select hdmi-tv-stereo as output in GNOME Sound App and the result is what I want: sound going through HDMI1. 

Version-Release number of selected component (if applicable):
pulseaudio-0.9.22-5.fc15.i686
alsa-lib-1.0.24-2.fc15.i686
kernel-PAE-2.6.40-4.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. Connect audio receiver to HDMI1
2. Select "HDMI" in gnome sound app output selector
3. Play sound
  
Actual results:
Sound comes through HDMI0 (not HDMI1) thus is not audible.

Expected results:
PulseAudio should provide profile and allow selecting HDMI0 and HDMI1.
(Best would be to autodetect which audiocard belongs to current Xorg device, but this is completely different scope; fixing profile should be much easier).

Additional info:

Comment 1 Tomasz Torcz 2012-03-21 18:25:25 UTC
Still a problem with pulseaudio-1.1-8.fc17.x86_64

Comment 2 Tomasz Torcz 2012-03-23 09:45:05 UTC
BTW, BIOS upgrade in the meantime enabled audio-output via DVI connector. So right know I have _three_ HDMI-audio devices (for DP, HDMI and DVI connectors) and only one option in Sound Preferences.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Comment 3 Tomasz Torcz 2013-01-04 12:15:08 UTC
Issue is solved by PulseAudio 2.0 (tested in F18).


Note You need to log in before you can comment on or make changes to this bug.