Bug 727934 - failure in dbus unit tests
Summary: failure in dbus unit tests
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dbus
Version: 5.8
Hardware: ppc64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Colin Walters
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 17:34 UTC by Vladimir Benes
Modified: 2015-08-03 11:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:00:41 UTC


Attachments (Terms of Use)

Description Vladimir Benes 2011-08-03 17:34:00 UTC
Description of problem:
when running dbus unit tests on ppc64 I can see some failures
#0  0x00396402 in __kernel_vsyscall ()
#1  0x00a69320 in __nanosleep_nocancel () from /lib/libpthread.so.0
#2  0x080be9a6 in _dbus_sleep_milliseconds (milliseconds=180000)
    at dbus-sysdeps-unix.c:2387
#3  0x080bd634 in _dbus_abort () at dbus-sysdeps.c:83
#4  0x080a9f5c in _dbus_warn (
    format=0x80eee74 "Fd %d did not have the close-on-exec flag set!\n")
    at dbus-internals.c:253
#5  0x080c5c9e in _dbus_spawn_async_with_babysitter (sitter_p=0x9ad0410, 
    argv=0x9ae0de0, env=0x0, child_setup=0x805adc0 <child_setup>, 
    user_data=0x9acd218, error=0xbfd4c1dc) at dbus-spawn.c:901
#6  0x0805a629 in bus_activation_activate_service (activation=0x9acd218, 
    connection=0x9ae0f20, transaction=0x9adbfd8, auto_activation=0, 
    activation_message=0x9ad0080, 
    service_name=0x9ad15dc "org.freedesktop.DBus.TestSuiteEchoService", 
    error=0xbfd4c1dc) at activation.c:1692
#7  0x0806ffa0 in bus_driver_handle_activate_service (connection=0x9ae0f20, 
    transaction=0x9adbfd8, message=0x9ad0080, error=0xbfd4c1dc) at driver.c:772
#8  0x08071146 in bus_driver_handle_message (connection=0x9ae0f20, 
    transaction=0x9adbfd8, message=0x9ad0080, error=0xbfd4c1dc)
    at driver.c:1774
#9  0x0806e0de in bus_dispatch (connection=0x9ae0f20, message=0x9ad0080, 
    user_data=0x0) at dispatch.c:239
---Type <return> to continue, or q <return> to quit---
#10 bus_dispatch_message_filter (connection=0x9ae0f20, message=0x9ad0080, 
    user_data=0x0) at dispatch.c:374
#11 0x08083d8a in dbus_connection_dispatch (connection=0x9ae0f20)
    at dbus-connection.c:4350
#12 0x080c3468 in _dbus_loop_dispatch (loop=0x9ae2d00) at dbus-mainloop.c:482
#13 0x080c3943 in _dbus_loop_iterate (loop=0x9ae2d00, block=0)
    at dbus-mainloop.c:848
#14 0x0807a13e in bus_test_run_everything (context=0x9ae2998) at test.c:288
#15 0x0806add2 in check_list_services (context=0x9ae2998, connection=0x9ace618)
    at dispatch.c:4217
#16 0x0806c1be in bus_dispatch_test_conf (test_data_dir=<value optimized out>, 
    filename=<value optimized out>, use_launcher=0) at dispatch.c:4519
#17 0x0806cafc in bus_dispatch_test (test_data_dir=0xbfd4c7c4)
    at dispatch.c:4653
#18 0x0807b221 in main (argc=175, argv=0xbfd4c884) at test-main.c:131

don't know if this can be somehow critical or is caused by test itself

Version-Release number of selected component (if applicable):
dbus-1.1.2-15.el5_6

How reproducible:
100%

Steps to Reproduce:
1.execute /desktop/rhel5/dbus/dbus-unit-tests from beaker
  
Actual results:


Expected results:


Additional info:

Comment 2 RHEL Product and Program Management 2012-10-24 11:58:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 3 RHEL Product and Program Management 2014-03-07 12:37:19 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 4 RHEL Product and Program Management 2014-06-02 13:00:41 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.