Bug 727948 - [RFE] systemd unit files should be installed on those platforms which support systemd
Summary: [RFE] systemd unit files should be installed on those platforms which support...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Corosync Cluster Engine
Classification: Retired
Component: unknown
Version: 1.4
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Angus Salkeld
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-03 18:32 UTC by Steven Dake
Modified: 2016-04-27 01:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-10 07:30:16 UTC


Attachments (Terms of Use)
patch with unit files (4.73 KB, patch)
2011-08-08 11:12 UTC, Angus Salkeld
no flags Details | Diff

Description Steven Dake 2011-08-03 18:32:36 UTC
Description of problem:
systemd unit files should be installed on fedora 15+ rather then init scripts.  The corosync package should contain the files and make a determination at build time whether to produce a spec file that contains systemd support or initscript support.

Comment 1 Angus Salkeld 2011-08-08 11:12:57 UTC
Created attachment 517174 [details]
patch with unit files

Comment 2 Angus Salkeld 2011-08-08 11:13:41 UTC
Initial patch posted upstream, waiting for feedback before moving to POST.

Comment 3 Angus Salkeld 2011-08-08 23:31:16 UTC
committed upstream (needs cherry picking into 1.4 branch).

Comment 4 Jan Friesse 2012-10-10 07:30:16 UTC
Long time fixed in upstream and Fedora.


Note You need to log in before you can comment on or make changes to this bug.